2

I've used Linux Mint 18 for a long time, but recently a strange problem has come up and I'd like to know how to understand the cause. Sometimes, especially during high CPU usage, mingled and ghost characters and other strange artifacts appear.

enter image description here

How to investigate the problem?

Sometimes the problem disappears when the high load terminates, but mostly I have to reboot the computer.

The problem doesn't come up when using Windows.

lshw returns:

*-display
description: VGA compatible controller product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller vendor: Intel Corporation physical id: 2 bus info: pci@0000:00:02.0 version: 09 width: 64 bits clock: 33MHz capabilities: msi pm vga_controller bus_master cap_list rom configuration: driver=i915 latency=0 resources: irq:31 memory:f7800000-f7bfffff memory:e0000000-efffffff ioport:f000(size=64)

I didn't manually update drivers/configuration, but I updated Mint as usual.

sensors returns (invoked just before launching GIMP and thus raising the glitch):

acpitz-virtual-0 Adapter: Virtual device temp1: +27.8°C (crit = +92.0°C) temp2: +29.8°C (crit = +92.0°C)

coretemp-isa-0000 Adapter: ISA adapter Physical id 0: +34.0°C (high = +87.0°C, crit = +91.0°C) Core 0: +34.0°C (high = +87.0°C, crit = +91.0°C) Core 1: +28.0°C (high = +87.0°C, crit = +91.0°C)

asus-isa-0000 Adapter: ISA adapter cpu_fan: 0 RPM

10
  • What are your display adapter and driver ? Have you updated your driver or configuration files ?
    – harrymc
    Mar 5 '18 at 20:13
  • 1
    Maybe graphic card overheating? Please specify your HW & drivers (graphic card, cpu, drivers). It would be also good to have a temperatures overview (see lm-sensors)
    – tukan
    Mar 6 '18 at 9:46
  • @Surfer on the fall: Why have you added a bounty if you aren't answering questions?
    – harrymc
    Mar 8 '18 at 7:22
  • @harrymc I had some serious issues so I wasn't able to retrieve the information required... Mar 10 '18 at 15:38
  • 1
    Thank you, but could you be more specific about your computer model and the hardware - it's hard to translate these ids.
    – harrymc
    Mar 10 '18 at 17:25
1
+50

An answer on the Linux Mint forums for the post of Drivers for Intel Graphics Card Linux Mint 18.2 treats this problem and has been verified by several readers. This answer lays the blame on old drivers still found in Linux which can be uninstalled for better results.

The described procedure is :

  • Execute in Terminal the command

    sudo apt-get remove xserver-xorg-video-intel
    
  • Reboot

  • Execute in Terminal the command inxi -G to verify that your video card was well detected.
  • Execute in Terminal this command for additional verification :

    grep modesetting /var/log/Xorg.0.log
    

The result of the command should look like :

[ 20.036] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 20.047] (WW) Falling back to old probe method for modesetting

If you wish to undo the above, just enter the following command and reboot :

sudo apt-get install xserver-xorg-video-intel
1

Linux systems are not exactly working with CPU-internal graphic "cards". I recently had this problem on a simple desktop with i7-8700K and Linux Mint (updated). There is a workaround with kernel option which is not working, so you may need to put a real graphic card into this computer. Nearly any cheap one.

There are no drivers for CPU-internal graphic card on Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.