My Crucial BX100 SSD is locked. I can’t unlock it with the correct (!) user password.

So I’ve searched all over google, and read in a thread that I should try to unlock it with the master password.

Unfortunately I haven’t found the master ATA password for Crucial drives on the internet.

Does someone know the ATA master password for Crucial drives?

I want to use the command:

hdparm --user-master m --security-unlock PASS /dev/sda

Or maybe someone knows another solution that could unlock my SSD.

Background: I wanted to secure erase my SSD drive. I've booted from a Knoppix Live CD and used the command:

hdparm --user-master u --security-set-pass PASS /dev/sda

After that I wanted to actually secure erase it with:

hdparm --user-master u --security-erase PASS /dev/sda

But it said the following with some and some more 00’s) at the end:

Bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 51 e0 00 21 04 …

Maybe important to know: Before that my drive has been frozen. I solved that by putting the system in Sleep Mode. After that the frozen-state has gone.

Maybe that led to the locked-state? I don’t know.

I’m a little bit desperate right here, hope you can help.

EDIT Mar 1-st:

I've found this thread today where someone has the exact same problem. In his case - they assume - there are controller-problems. Maybe i'll confront Crucial with that info in the next days.

And for further information: I've tried the following commands, too:

hdparm --user-master m -- security-disable NULL /dev/sda


hdparm --user-master m --security-erase-enhanced NULL /dev/sda


Bad/missing sense data, sb[ ]: 70 00 05 00 00 00 00 0a 51 e0 00 21 04 

fdisk -l


i/o (input/output) Error
  • Have you tried skipping the unlock, and instead simply set a new master password? Mar 1, 2018 at 0:01
  • FYI, just so you know why I edited the title: Basically if your drive were locked with data that you wanted to access, that is one problem. But if the erase process failed and that is causing the lock, that is an entirely different thing. I doubt data recovery in a case like this would be possible, but figuring out how to wipe it again should definitely be doable. Mar 1, 2018 at 0:02

3 Answers 3


If by "locked" you mean at the ATA Secure Erase level, you should be able to initiate a new erase with a new master password, regardless of what the old password was:

hdparm --user-master m --security-set-pass NEWPASS /dev/sda

This is the only action permitted for a drive that has been locked in preparation for erasure, or for a drive that was in the process of being erased.

This is because the purpose of the lock is to prevent someone from interrupting an erase, and then accessing any remaining data.

But if all someone wants to do is to repurpose the drive and discard any previous data, then initiating a new erase should work (as long as the drive is in good working order).

  • Thank you very much. Just tried it: but didn't work... It says the same as above: >! Bad/missing sense data, sb[ ]: 70 00 05 00 00 00 00 0a 51 e0 00 21 00. Do you know another solution?
    – Dellicious
    Mar 2, 2018 at 0:20
  • 1
    You wouldn't happen to be attaching the drive via USB-to-SATA, would you? If so, can you try with a direct SATA connection? Mar 2, 2018 at 6:11
  • Funny enough, I got the nearly the same sense on a secondhand seagate Exos X16 when trying this stuff, 70 00 05 00 00 00 00 0a 04 51 40 00 21 04 00 00... And seller knows nothing about the password! Jun 18, 2023 at 6:53

Ok guys, the replacement WORKED! I encourage everyone who runs into the same problem to send Crucial a warranty replacement request.

My experience: - Crucial tries to get rid of you (at least on telephone) when you say you use this drive with Linux and then the problem occured. They said something like: "we don't support Linux" (which is - in my opinion - idiocy and not to heard to). And actually one guy told me something like "the drive is not beeing replaced if the drive got bricked whilst using Linux". This is to be ignored. I got the impression that they tried to blame me, instead of listening to my statement that i did nothing wrong and it has to be a hardware failure.

SO - my tip: if you send it back just don't mention something about using it with Linux (at least in the actual replacement request*). Just say it doesn't work with Windows 10, and you are good to go. Then you shouldn't run into problems.

*In a general service mail that i sent before the staff was very helpful, even by mentioning Linux.



I think there's no doubt that it is a hardware problem.

I will contact Crucial to - hopefully - get the SSD replaced.

(Explanation for this in this post further down.)


You wouldn't happen to be attaching the drive via USB-to-SATA, would you? If so, can you try with a direct SATA connection?

-> No, it's not conected via USB-to-SATA. It's connected directly to the motherboard via SATA-connection.

Explanation for my assumption it's a hardware problem:

1) I've tried everything that is possible on the software-level - and nothing worked for the ssd:

  • all possible commands in the Linux terminal (see above) - including Royce' command:

    hdparm --user-master m --security-set-pass NEWPASS /dev/sda

  • plug SSD to another SATA-Port on Mainboard
  • switch SATA-Option in UEFI/BIOS between IDE and AHCI
  • installing "Crucial Storage Executive" on Windows and trying to secure erase it using the function "PSID revert" (like the Crucial support told me to) -> didn't work

    • both "Storage Executive" and Windows don't recognize the SSD (not even Windows Disk Management).
    • Info: Both UEFI(BIOS) and Linux recognizes the SSD
  • flashing the firmware over a USB-boot-drive -> not working:

    CMD_Status: Command aborted by the drive | STATUS_CODE: 13

2) As i've written in my opening post (in the "Edit March 1-st"-section), i've found this thread. According to the answers there, it could be a bad programmed controller, viz. hardware failure. And i'm pretty sure they are right and that this applies to my drive - Crucial BX100 - , too.


It actually looks like the BX100 from Crucial gets bricked if you add a security password over Linux.

This might be a bad programmed controller.

I'll contact Crucial support (there's still warranty left) and tell you if the replacement worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .