2

Whenever I import a book co the Calibre eBook manager library it converts the names/titles to English removing all the accents from European words and replacing non-Latin (e.g. Russian) words with their romanizations.

There is no technical necessity in this in the today world of Unicode and it also harms usability as it is always easier to read (and search for) a word in its original script rater than a romanization if you are fluent in it (and I obviously am sufficiently fluent in all the languages I read books in).

The Preferences - Saving books to disk - Convert non-English characters to English equivalents checkbox allows you to turn this off for books exporting but it will still romanize the names of all the files in both the local library and the reader device library.

How can romanization be possibly turned off for the libraries files names?

1

A solution is to convert books and after that to export them (by pressing Save button). That's all.

Of course, you have to have transliteration checkbox disabled. (Preferences - Saving books to disk - Convert non-English characters to English equivalents)

This way, books stored in the "Calibre Library" will be saved with transliterated names, but books in your final destination will have non-transliterated names.

In some languages, as Bulgarian, transliteration works buggy and generates very strange names (3.23). Because of this I needed transliteration disabled so much.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.