0

In our office we have a handful of windows 10 PCs. Out of the box some of the PCs could access the shares on NAS and some couldn’t. I managed to get access working on the ones that couldn’t access it by reducing the SMB version on the NAS to 1.0. Then I was unable to access on my PC (which was previously working), getting an error saying the SMB 1.0 was not supported. I tried changing the SMB version to 2.0 on the NAS, then after rebooting my PC a windows update occurred and now am unable to connect from my PC for any SMB version and am now getting a generic error message “Windows cannot access \MyClouldEX2Ultra”, clicking on show details shows “Error code 0x80004005 unspecified error”.

Here is what I have tried.

  • Enabled NetBIOS over TCP
  • Checked network discovery was turned on
  • was able to ping the device by IP and by name
  • was not able to access share by IP or name
  • tried setting the NAS to SMB 1.0, 2.0 and 3.0
  • rebooted the PC rebooted the NAS
  • I know you changed smb modes on the NAS. But just to make sure that actually happened, enable SMB v1 in Windows 10. It is done through programs and features. There is also a “feature” that now automatically removes the SMB v1 feature if it is not “needed.” – Appleoddity Mar 2 '18 at 5:48
  • Thanks, this did the trick, but am I don't know why we need use SMB v1 in the first place, surely windows 10 should support SMB v3 out of the box. I just worry that if Microsoft decide to stop supporting v1 altogether in the future things will stop working again. Also, they say SMB v3 performs better than v1. – Shane Mcpherson Mar 2 '18 at 6:28
  • I think it is the other way around. I think your NAS isn’t supporting, or isn’t properly implementing, the newer protocols. – Appleoddity Mar 2 '18 at 6:33
  • Something weird is going on, yesterday I was able to access the NAS when it was set to SMB v3, today I can't. The only thing I can think of that has changed since yesterday is a windows update. – Shane Mcpherson Mar 2 '18 at 8:10
  • Exactly. Like I mentioned, Windows is disabling SMB v1 automatically. That feature can be removed. I think you’ve been using v1 all along. – Appleoddity Mar 2 '18 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.