1

I'm trying to relocate a backup folder to an external hard drive with mklink. When I run the command I get the error "the file already exists" (that's the Korean underneath the command): enter image description here

(The won sign where the backslash should be, is the backslash. It just comes up in Korean on my computer.)

I have literally tried EVERYTHING. I deleted the Backup files and tried it. But doesn't work. What can I do?

2
  • Does E:\Iphonebackup already exist? If so, remove it, because that's the reason why you get the error.
    – LPChip
    Mar 2 '18 at 14:57
  • Had to delete the original Backup folder from Itunes before it could create the link.
    – juanvan
    Sep 2 '20 at 0:45
1

You need to remove the redirected folder first (emptying it out is not sufficient). mklink can't transmute directories into junctions; the name has to be available before it can create the junction. Try renaming the Backup folder to something else, creating the junction with your first command, then moving any desired files back into the now-redirected folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.