0

I cannot use netsh WLAN command when the network I am trying to work with contains whitespace. For eg: While working with a network with SSID "Some Network"

C:\Users\Padmanava>netsh wlan show profile Some Network key=clear
There is no such wireless interface on the system.

But when working with a network with SSID "SomeNetwork" It works perfectly fine

C:\Users\Padmanava>netsh wlan show profile Lenovo key=clear

Profile Lenovo on interface Wi-Fi 2:
=======================================================================

Applied: All User Profile

Profile information
-------------------
    Version                : 1
    Type                   : Wireless LAN
    Name                   : Lenovo
    Control options        :
        Connection mode    : Connect automatically
        Network broadcast  : Connect only if this network is broadcasting
        AutoSwitch         : Do not switch to other networks
        MAC Randomization  : Disabled

Connectivity settings
---------------------
    Number of SSIDs        : 1
    SSID name              : "Lenovo"
    Network type           : Infrastructure
    Radio type             : [ Any Radio Type ]
    Vendor extension          : Not present

Security settings
-----------------
    Authentication         : WPA2-Personal
    Cipher                 : CCMP
    Security key           : Present
    Key Content            : not_your_network

Cost settings
-------------
    Cost                   : Unrestricted
    Congested              : No
    Approaching Data Limit : No
    Over Data Limit        : No
    Roaming                : No
    Cost Source            : Default

Is there any way to work with networks with SSID containing whitespaces.

Also, I don't have access to the router so I cannot change the SSID.

  • If the SSID contains spaces you have to use quotes around the name. – Ramhound Mar 2 '18 at 14:59
0

You should use quotes for SSIDs having spaces.

Example: if your WiFi's name is WiFi Hotpot, write it in the command as "WiFi Hotspot".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.