10

The Wi-Fi connection I currently connect to has both 2.4 GHz and 5 GHz bands on the same Wi-Fi connection (not separate names).

My Windows 10 laptop can make a connection to either 2.4 GHz or 5 GHz. I have set it to prefer 5 GHz, but it will still occasionally connect to 2.4Ghz.

Is there any way of preventing my laptop from connecting to 2.4 GHz frequencies and to only make use of 5 GHz frequencies?

12
  • 6
    Why not just change the name of the two networks so this is never a problem again on any equipment? Mar 2, 2018 at 17:59
  • There is only one network. Both bands operate on the same WiFi connection (only 1 network profile is created in Windows when connecting to this point for both the 2.4Ghz and 5Ghz). I tried seeing if there was a 2.4Ghz profile I could disable but there was no luck.
    – Berrik
    Mar 2, 2018 at 18:03
  • 6
    @Berrik we understand that you see only one network name. If the network is yours, you can easily change that. Reconfigure the router / wireless access point. There is no rule that both bands have to show up as a single network. Matter of fact, that is typically the wrong way to set it up - and now you see why. Mar 2, 2018 at 18:08
  • 1
    The issue here is literally that both bands are broadcasting the same SSID... Your laptop may prefer the 5Ghz band, but if it thinks that the 2.4Ghz signal will provides "better" service, it will move to it automatically unless you specifically disable the 2.4Ghz band entirely. If each hand is broadcasting a unique SSID then you can set the connection properties accordingly and force connection to the 5Ghz band.
    – acejavelin
    Mar 2, 2018 at 18:12
  • 1
    Depending on your wireless adapter manufacturer, some manufacturers offer a windows supplicant/application to drive your adapter. In some of those supplicants, it is possible to disable 2.4GHz. Unfortunately, the embedded windows wifi supplicant will never try to deny you connectivity. Although you can set the connection to prefer 5GHz, it will revert to 2.4GHz in order to maintain connectivity should something go wrong on 5GHz. Your best option is to look for your wifi adapter manufacturer windows supplicant. For example, Intel has a supplicant called ProSet.
    – pythonian
    Mar 2, 2018 at 18:46

4 Answers 4

6

You can specify what band your wireless card will connect to in the advanced driver settings found under your wireless card in device manager.

If you don't want to connect to 2.4ghz disable the associated bands, i.e 802.11 b/g/n on 2.4ghz.

This solution depends on your wireless card and driver's, but most wlan nics I have seen have these options.

If you find that your card doesn't have the band settings, you may want to do something like ramhound & Pythonian suggested, not use Microsoft generic drivers with the card. But download the chipset specific driver/application.

The other option as people stated in the comments would be to change the SSID (network name) of the 2.4ghz network to anything other then the SSID that's associated with the 5ghz network.

1

Open Control Panel, and then click on "Change adapter settings" (this should appear on the left side pane). Right click on Wi-fi (or the equivalent name), and click on Properties. In the new dialog box, click on "Configure...", which will lead you to a dialog box with multiple tabs. Click on Advanced, and select "Preferred Band". Within the dialog box, on the right side, you will find 3 preferences: 1. No Preference 2. Prefer 2.4 Ghz 3. Prefer 5 Ghz

Select your preference and click OK until you close all the dialog boxes. Your wifi adapter should reset and connect to your preferred bandwidth.

This is how I connect to 5 Ghz automatically on my Windows 10 laptop. Settings and nomenclature could change with different versions of Windows, or even with different wifi adapters, but I think this is a common process.

Hope it works for you!

2
  • 1
    I've tried this; this doesn't actually force the connection to be 5 GHz. My guess is it's because it only works if the card sees both of the networks simultaneously, otherwise it will think the 5 GHz network doesn't exist and will just connect to 2.4 GHz.
    – user541686
    Nov 28, 2020 at 9:53
  • This differs between adapters - I don't have this option at all on a Broadcom PCI-E card
    – Cocowalla
    Sep 26, 2022 at 21:30
0

You can Specify the band while creating the wireless Network in Router and you can name it 2.4Ghz and 5Ghz. 5Ghz range is small while the 2.4Ghz range is large. Also, go to device manager -> network adapter -> wifi device -> advance setting -> preferrable band --> 5Ghz first.

Then connect your Windows 10 device with a 5Ghz network. Your device will be always connected to the 5Ghz network.

0

I had the same problem after reading all the answers in here I found solution for my self. If you are able to connect to the 5Ghz network look into its properties at the Protocol for example mine is ruining 802.11ac , go into device manager find your WiFi adaptér go In to advanced and there select Wireless Mode and select the protocol at which your 5Ghz WiFi is ruining, it worked for me since I don't have any option in my adapter setting to select preferred frequency or disable the protocol at which the 2Ghz WiFi is ruining so I had to force it for the exact band the 5Ghz network is ruining but if you ever need to connect to different WiFi you should put the Wireless Mode back to auto. It's much more simple then messing with your router

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .