The problem started when my LAN connection stopped working: only one green light on Ethernet controller was lighting, network was beeing identified for a long time, then it became Unknown network.

To resolve this, I tried deleting network adapters in Device manager and restarting PC. These devices were re-installed (they are present in device manager), however, both LAN and Wi-Fi are not working now. Network Connections folder is empty, there is no Wi-Fi icon in tray anymore, only Airplane mode. There are two Base System Devices and Unknown Device which haven't their drivers installed. Network Services are on. Network Setting Reset did not help, either.

My network adapters are: Intel Centrino Wireless-N 2230 Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30)

  • The lan not working either makes me think your router is kicking the bucket or overheating. Have you power cycled it? – Tim_Stewart Mar 3 '18 at 10:38
  • Yes, that was one of the first things I did. Router shows that LAN1 is connected – kirus Mar 3 '18 at 10:48

You can try the following to resolve the issue:

Fix 1

  1. Type regedit in RUN or Start search box and press Enter. It'll open Registry Editor.

  2. Now go to following key:


  3. In right-side pane, you'll see a multi-string key ClassManagers. Double-click on it and it'll open the edit dialog box to change its value.

  4. The dialog box will contain 4 GUIDs and each GUID must present on a separate line. If you find that all GUIDs are present in a single line, put them on separate lines by pressing Enter key after each closing curly bracket '}'.

The correct values for the key are;


You can copy the above text and paste it in the edit dialog box.

Fix 2

  • Open Command Prompt as Administrator and run following commands one by one:

    reg delete HKCR\CLSID\{988248f3-a1ad-49bf-9170-676cbbc36ba3} /va /f

    netcfg -v -u dni_dne

If you encounter an error while performing the commands above , manually delete this key:


(While you are on {988248f3-a1ad-49bf-9170-676cbbc36ba3} key, press Delete key to delete the key from Registry).

then run the second command netcfg -v -u dni_dne


| improve this answer | |
  • Hi, I've already tried that before your response, however, it did not help. Thanks! – kirus Mar 5 '18 at 17:47

Following things did not help solving this problem:

  • Deleting network adapters and rebooting to re-install them
  • Upgrading network adapters' drivers
  • Deleting all information about network adapters in Registry
  • Recovering damaged system files via sfc /scannow
  • Clearing DNS and IP configurations
  • Fix 1 and Fix 2 provided by xavier_farakat

Reintsalling Windows solved the problem. My advice for you is to always have an USB with Windows image.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.