10

I am using Firefox (version 58.0.1) and for awhile now, Firefox and other browsers have implemented this feature known as 'Push Notifications.'

It now seems like every site wants to 'Push' notifications to you. This has become a new form of pop-up, and is an intrusive technology. Because of this constant bombardment of push notification requests, I wish to completely disable push notifications.

I do not wish to disable on a site-by-site basis. I want to disable this 'feature' completely, for every site, forever.

sample push notification request

I have looked through the Firefox settings, and through the documentation on the Mozilla website, but there is nothing official on how to disable the Push Notifications. 2

  • 2
    Best practice for this API is that sites should first tell you why they need notifications, and only then request permission. However there's a plague of sites that ask for this permission without any context. I'm worried that a useful feature gets degraded this way – Kos Mar 4 '18 at 7:41
  • 2
    The amusing thing is, I'd really like a leading network of QA sites to support this... – Journeyman Geek Mar 4 '18 at 8:19
  • @Kos While I agree in principle, the abuse of this feature for antipatterns is already quite evident, unfortunately. I actually wonder how the W3 thought that this would not be abused. I think the only way for this work is for sites work in an opt-in request model, without the popup, because that is what this is, just a new version of popup Windows. – David Mar 4 '18 at 10:48
7

From further research, I discovered that you have to go into the about:config interface. HERE BE DRAGONS! (1) Or if you use the American locale, Your warranty might be voided (2)

I changed four settings to FALSE:

  • dom.webnotifications.enabled
  • dom.webnotifications.serviceworker.enabled
  • dom.pushconnection.enabled
  • dom.push.enabled

(1) Here be dragons:

Here be dragons

(2) This might void your warranty: This might void your warranty!

  • 2
    Definitely a good Q&A! That being said, while the whole Here Be Dragons thing is rather amusing, perhaps it depends upon version and/or your regional locale. I am utilizing the En-US 64-bit version of Firefox 58.0.2, and my about:config page never says that. – Run5k Mar 3 '18 at 18:20
  • 1
    @Run5k - I have added a screen capture for you. I have always seen this. – David Mar 3 '18 at 18:53
  • David, I know that you have the best of intentions, but please remember that this answer isn't specifically for your benefit. It is designed to help the community as a whole, and we have already established that the humorous Here be dragons! screen is strictly a regional version. As a result, it could potentially confuse a large percentage of the people viewing this answer. Including it is simply unnecessary, and actually a bit counterproductive. – Run5k Apr 14 '18 at 22:41
  • @run5k - I think you are missing my point, which is to alert people that they can severely mess up their firefox. I would appreciate if you would add the link to your warning screen, rather than to remove the content that I have added. And I would not like to assume that 'people should know better'. I would like to have a warning. – David Apr 17 '18 at 10:29
  • On the contrary, good sir. My goal is to take good care of the end-users, also... and not just the ones who live in the UK. Notably, you didn't have any type of "alert" or warning within your original answer (either a written explanation or screen shot) before my original comment. Please, don't get me wrong: I was simply trying to help a very good answer become even better. But when I showed your tutorial to several different American end-users, most of them stopped because they thought they were on the wrong screen. However, now that this is built into the options page it is a moot point. – Run5k Apr 17 '18 at 13:06
6

With the release of Firefox 59, we can now disable push notifications using the default Options page.

The official release notes for Firefox 59 described the modification:

Added settings in about:preferences to stop websites from asking to send notifications

You can configure this option in the following manner:

  1. Navigate to the about:preferences page
  2. Click on Privacy & Security on the upper-left
  3. Scroll down to the Permissions section on the right
  4. Click on the Settings... button associated with Notifications

    Privacy & Security

  5. In the subsequent window check the box to Block new requests asking to allow notifications
  6. Click the Save Changes button

    Settings - Notification Permissions

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.