I recently got a Windows Home Server (HP MediaSmart Server EX490) setup so I could do backups and other things. However, I am having trouble on my Vista 64 PC. The backup will be making great progress, then it will just slow down. At one point, I noticed the lights on my Netgear GS105 indicated it was not using a 1000 Mbps connection, but a 10 Mbps one. I checked the Status of Local Area Connection (Intel(R) 82567V-2 Gigabit Network Connection) and that also showed the same slow speed. This has happened several times in the last couple days.

When I disabled the network device, and then enabled it, it established the 1 Gpbs connection again. However, some of the times the Sent Bytes Activity on the Status windows indicate that the data flow is still slow (100 to 1000 bytes every couple seconds). Obviously, at this rate I could backup faster to floppy disk. :)

My question is how to diagnose and fix this problem. When I look at the Administrative Events, I do a Errors:

Bonjour Service  456: ERROR: read_msg errno 10054 (An existing connection was forcibly closed by the remote host.)

And a Warning:

e1yexpress  Intel(R) 82567V-2 Gigabit Network Connection Link has been disconnected.

I am suspicious there is some power saving mode. I found a post suggesting System Idle Power Saver(SIPS) may be the issue. I am going to try that, but looking for other suggestions or diagnostic advice. I have several new items in this configuration: server, client software, switch and cat6 cables.

  • I'll be curious to see if you can get this fixed. My Vista x64 is also painfully slow at transferring over Ethernet. Others claimed that the latest SP fixed it, but not for me. :-( – Brian Knoblauch Apr 12 '10 at 13:41
  • looks like cable-quality related – user8228 Apr 13 '10 at 5:33

Disabling System Idle Power Saver(SIPS) did it for me. I backed up just under 300 Gig in 2 hours and 50 minutes.


All SIPS settings were disabled (Driver Properties and in the Registry) but I still had disconnection issues. After digging into many posts about Intel NICs which had the problem, one guy mentioned to turn off the DNS Registrations on all TCP/IP protocol stacks. That fixed it for me. I don't know if this is something to do with my Cisco router?

  1. Control Panel\Network and Internet\Network Connections
  2. "Local Area Connection" properties
  3. "Internet Protocol Version X (TCP/IPvX)" properties (X can be 4, 6, do it for both)
  4. Advanced...
  5. DNS tab
  6. Uncheck "Register this connection's addresses in DNS"
  • Well, that didn't fixed it, was too fast in my previous post. I still get the same error. I am not getting this error on Linux (same machine - dual boot). So this is not the cable. I suspect the Windows Driver. – Yves Tremblay Aug 30 '11 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.