According to this URL I should be able to start Komodo IDE from the command line when I want to edit a file.

I set up the symbolic link using (on single line)

ln -sf "/Applications/Komodo IDE.app/Contents/MacOS/komodo" 

but when I type

afg-2:~ lexu$ komodo .bash_profile

I get

dyld: Library not loaded: /usr/lib/libsqlite3.dylib Referenced from: /System/Library/Frameworks/Security.framework/Versions/A/Security Reason: Incompatible library version: Security requires version 9.0.0 or later, but libsqlite3.dylib provides version 1.0.0 /Applications/Komodo IDE.app/Contents/MacOS/run-mozilla.sh: line 131: 4370 Trace/BPT trap
"$prog" ${1+"$@"}

and a dialog that says:

komodo-bin cannot be opened because of a problem

My guess is I need to somehow let Komodo know it needs to use different libraries?

Does someone have this working?


Add alias ki='/Applications/Komodo\ IDE.app/Contents/MacOS/komodo-bin' to your ~/.bashrc

Then just do $ ki somefile

EDIT: Changed it, didn't realize you were using Komodo IDE

| improve this answer | |
  • I'd tried that before, but got a different error that lead me to believe starting the '-bin' was a nono! (I'll add that as an Edit to the Question though!) – lexu Apr 12 '10 at 14:41
  • 1
    OOPS: I just realized you are going the alias route .. that worked! Problem solved! – lexu Apr 12 '10 at 14:47

Does it work if you call the program directly from it's regular location? If so, then very likely there is a dependency on where the program is located. To get around that you could, instead of having a symbolic link in ~/bin/komodo, make that file a small script such as:

exec /Applications/Komodo IDE.app/Contents/MacOS/komodo

Change the permissions of that file with "chmod 755 ~/bin/komodo". Then it should work (assuming the problem was that it worked OK from its original location).

You could also adjust your PATH variable to include /Applications/Komodo IDE.app/Contents/MacOS . Then there would be no need to have a symbolic link or script in your ~/bin .

| improve this answer | |
  • Nope, didn't work, I get the same error when using exec – lexu Apr 12 '10 at 14:42
  • exec /Applications/Komodo\ IDE.app/Contents/MacOS/komodo-bin did work however! Thanks for teaching me about exec! – lexu Apr 12 '10 at 14:51

The way I do it is have ~/bin/komodo.sh which has

/Applications/Komodo\ IDE.app/Contents/MacOS/komodo-bin "$@"

I then have ~/bin as part of my path

I can then do

$komodo index.php

and it loads. However because I like to be even quicker, I have a shell alias which is:

alias kom="komodo"

so that I can do:

$kom index.php
| improve this answer | |

the exec solution kind of worked for me but when closing the Komodo window/app it closed my iTerm (with all of it's tabs :-(

For an OSX'ian approach:

open /Applications/Komodo\ Edit.app

If you associated files with komodo you can call open from the command line. e.g. if you right click on a .py file and click on get-info, say open-with komodo and click on Change-All, you can then from the command line just say:

open somefile.py

| improve this answer | |

That FAQ is out of date. We'll make sure that gets updated. The best way to start komodo from the command line on OS X is to use 'alias' like so:

alias komodo='open -a "Komodo IDE"'


alias komodo='open -a "Komodo Edit"'
| improve this answer | |
  • Thanks for the replay, please edit your reply and add a path to the new FAQs, when available. – lexu Jan 10 '11 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.