1

I run a server on a residential connection with a static IP.

My residential connection blocks listening on port 80, but I can set the server to listen on any port.

I own a domain name and currently manage the DNS through GoDaddy.

I've tried messing with the DNS SRV and A records to no avail.

Do I need a VPN tunnel/proxy/different DNS manager/another local web server? What are the next steps I can try to accomplish this?

2

If you have a static IP, simply use an A record to point it to your IP address. You won't be able to get http to translate another port to port 80 - you will need to fix your router or use a the form http://domain.name:port

If https is not blocked you can try an https connection on port 443 instead.

Your router may be blocking port 80 because it has a web interface - maybe you can change it to behttps only or otherwise not bind to port 80

Also - if you have not already done it, you need to set up a port forward in your router so it knows which internal server to push the web requests to. This will also imply assigning an unchanging address to the web server (which can be done via static assignment or DHCP reservation)

  • I suspect that the OP is saying that their ISP is blocking incoming HTTP connections.  (Randall Lee: please clarify.)  So the question is, “Can I configure my domain name in DNS so that, when people try to connect to randall.lee.example.com, they get redirected to port 8080 at the DNS level?  And I believe that the answer is “No, you’ll just have to tell your users to connect to randall.lee.example.com:8080.” – Scott Mar 6 '18 at 20:37
  • @scott - I agree that it is a possibility the ISP is perceived as blocking port 80, and that this could be the case - but its also a lot more likely that the ISP is not blocking port 80 but the router makes him think it is. – davidgo Mar 6 '18 at 21:10
  • @scott pretty weird situation. ATT does block listening on port 80 in a way, like if I set my server to listen on 80, forward the port, then try to access it from outside my network and just punch in my public IP, it doesn't connect. However I did set up nginx to forward 80 to 5000 (arbitrary port # I set my server to listen to) and it didn't work until I once again forwarded port 80. Oh and GoDaddy screwed up and didn't actually lease the domain to me, just gave me hosting. Fixed, added the A record, now all is well. Thank you both. – Randall Lee Mar 6 '18 at 21:23
  • @RandallLee - Are you able to connect to port 80 externally and then forward it in to - say for example port 5000 internally ? If thats the case, then the problem is not AT&T (unless its on an AT&T supplied customer router which cant be reconfigured) – davidgo Mar 6 '18 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.