0

The problem is that after some period of time VirtualBox Manager wouldn't display information about any guest virtual machines. All the sections of details screen contain the same text: "Information Inaccessible". Like this: enter image description here

If I close this window and start the Manager again - everything is fine, information is displayed correctly. Until half an hour later, when it becomes inaccessible again. Already started guests continue running, but new guests can't be started.

Trying to investigate the problem I have uninstalled the VirtualBox and installed the latest version (it's 5.2.8). I have created two guest machines: one for Windows 7 guest, the other one for RedHat linux. All other options are default. No guest operation systems actually installed into these guests, and guests not started.

When I start VirtualBox Manager everything is ok. I do not even power on any guests, just switch to some other application. When later on (in about 10-30 minutes) I switch back to VirtualBox Manager the information about guests is already inaccessible.

My host OS is Win 10, all the latest updates installed. No antivirus.

VirtualBox log files contain several error messages like this:

00:00:28.938528 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'C:\Users\alexander.korshkov\VirtualBox VMs\Win7\Win7.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:00:28.939531 main     ERROR [COM]: aRC=VBOX_E_OBJECT_IN_USE (0x80bb000c) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Medium 'C:\Users\alexander.korshkov\VirtualBox VMs\Cent7\Cent7.vdi' cannot be closed because it is still attached to 1 virtual machines}, preserve=false aResultDetail=0
00:00:28.942536 Watcher  ERROR [COM]: aRC=E_ACCESSDENIED (0x80070005) aIID={9570b9d5-f1a1-448a-10c5-e12f5285adad} aComponent={VirtualBoxWrap} aText={The object is not ready}, preserve=false aResultDetail=0
00:00:28.943531 main     VirtualBox: object deleted

Any ideas about how to fight this problem are welcome.

UPDATE

This problem persisted for over a month, but looks like it's solved now. It's gone after I turned off "Fast startup" option on my host Windows 10 system and rebooted the system.

I am not absolutely sure, but looks like I have not rebooted the host system since VirtualBox was installed. (Yes, VirtualBox suggested reboot after installation). I have shut down the host computer several times, but they say that with "Fast startup" option turned on the shutdown is not good enough. Most probably the simple reboot would have solved the problem as well as the "shutdown/power on" with "Fast startup" option turned off.

  • You can try using the command line to clean up/rename/start VM's in a way that may be blocked in the UI – trapezoid Mar 7 '18 at 14:50
  • After it's unavailable, can you check wheter VBoxSvc is still running? – davidbaumann Mar 7 '18 at 15:16
  • @davidbaumann Yes, VBoxSVC service is still running when all the guests are inaccessible. As well as VirtualBox.exe. – lesnik Mar 12 '18 at 6:09
0

It could be you are running multiple instances. Check you in task manager that you are not starting multiple instances of the VM manager see this link https://forums.virtualbox.org/viewtopic.php?f=6&t=41630

  • When I start VirtualBox Manager two new processes appear in Task Manager: "VirtualBox.exe" and "VBoxSVC.exe". When I close the manager window, both these processes disappear. So I guess it's a single instance. – lesnik Mar 7 '18 at 14:41
  • Vboxsvc seems like a service. Does it still persist? – arthur kamande Mar 8 '18 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.