I've recently restored my MacBook Pro 2011 to a new machine. Things are generally getting back to working order, running 10.13.3. However, when I use ssh I am being asked for my passphrase each time.

I have tried to use macOS keeps asking my ssh passphrase since I updated to Sierra and looked up existing passphrase using https://superuser.com/a/1140285/657663 without success. Tried changing the passphrase, but I still get $ ssh-add -K ~/.ssh/id_rsa Enter passphrase for /Users/myuser/.ssh/id_rsa: Bad passphrase, try again for /Users/myuser/.ssh/id_rsa:

Suggestions?

  • 1
    Is the problem that it asks you for the passphrase each time, or that it does this and you don't know the passphrase? – Autumnal Mar 7 at 23:35
  • Objective is to make it so I never am asked for passphrase. Current hurdle to solving this is that the passphrase entered for ssh-add -K ~/.ssh/id_rsa that I retrieve for ~/.ssh/id_rsa from Keychain Access app doesn't work. – Joe Murray Mar 7 at 23:44
  • So have you been able to successfully use id_rsa without the agent at all/ have the passphrase somewhere else? – Autumnal Mar 8 at 0:27
  • I've not been successful since restoring the system in ssh'ing in using my id_rsa to servers where it used to work. I am asked for the id_rsa passphrase, I provide one, it then asks for my user's linux password for the server I am ssh'ing to. :( – Joe Murray Mar 8 at 0:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.