I am tying to connect to Windows 10 machine from a macOS Sierra using Microsoft Remote Desktop. The Windows machine is behind a switch. Both machines run on a local network.

I can connect to it using IP, but I can't using hostname. I've got the hostname from router DHCP table.

Error when trying to connect with hostname:

We couldn't connect to the remote PC because the PC can't be found. Please provide the fully-qualified name or the IP address of the remote PC, and then try again. Error code: 0x104.

What could be the reason and what should I do?

  • are you sure the hostname resolves on the Mac? Perhaps it isn't set to use your router for dns. – Garr Godfrey Mar 9 '18 at 15:07
  • Under Prefernces->Network->Advanced->DNS I have DNS server address Shouldn't that do it? – sanjihan Mar 12 '18 at 8:40
  • probably not. Your router probably understand internet DNS but not on your LAN. Mac and Windows use different protocols – Garr Godfrey Mar 13 '18 at 21:00

I recently just encountered and solved this exact error with Microsoft Remote Desktop Version 10.3.12 (1801) on both macOS High Sierra (10.13.6) and macOS Catalina (10.15.5). I was able to connect without issue if the IP address of the Windows machine was used, but would get Error Code: 0x104 if the hostname was attempted.

The solution that worked was appending ".local" to the end of the host name.

One thing to note is the iOS/iPadOS version of the app worked without any problems, and did not require anything added to the hostname.

| improve this answer | |

Delete any custom DNS server(s) under System Preferences » Network » Advanced » DNS and use the local network's DNS to get it to resolve via hostname.

| improve this answer | |
  • This was my exact problem. You prevented (additional) hours of heads banging against walls. Thanks!! – Lanny Bose Jan 11 '19 at 12:08

All you need to do is flush the DNS:

  1. Open CMD and type ipconfig /flushdns and press enter.
  2. Wait to when it has been done!
  3. Write down ipconfig /registerdns and press enter.

Wait 10-15 minutes and try again to connect not using the IP.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.