2

I recorded all of my CD's by burning them onto my PC with Windows Media Player. I have all of the .wma files and they cannot be opened by any media source I've tried, be it Groove Music or VLC or Windows Media Player.

I'm told by;

VLC PLayer - Could not demux ASF stream: DRM protected streams are not supported. VLC can't recognize the input's format:

Windows Media Player - encountered a problem while playing the file.

Groove Music says - Try playing this with a different player. This application doesn't have content usage rights.

I've looked and looked for a solution and I can't find what I'm looking for. I'm quite a novice regarding digital music, and I really want to play my cd's.

2
  • 1
    You “burned” your CDs incorrectly. There is no solution to your problem other than doing it correctly. – Ramhound Mar 9 '18 at 19:15
  • @sasha - The only solution to this problem is to properly rip the disk, see the accepted answer, for more information. – Ramhound Mar 17 '20 at 16:41
0

In WMP's Options, on the Rip Music tab, there's a checkbox called Copy protect music. I assume that this checkbox is/was ticked on your system, causing WMP to add DRM protection to all .wma files that are ripped from CD. As a result, these files can't be played anymore when the required DRM licenses aren't present anymore, for example, after switching to a new PC.

The only solution is to untick Copy protect music and rip the CDs again.

1
  • It's a shame I gave the cd's to sue ryder after I had ripped them! Thanks so much for telling me what you did. 👍👌 – Adobrob Mar 15 '18 at 22:18
0

Microsoft themselves has a tool which removes the DRM from WMA files: It's called Digital Rights Update Tool https://www.microsoft.com/en-us/p/digital-rights-update-tool/9nblggh52q93

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.