I am trying to install Visual Studio 2017 Community Edition on a Windows 10 machine which was recently reformatted. There's hardly anything installed but it is up-to-date in terms of Windows Updates. I have no Antivirus software and no firewalls.

When I open vs_community.exe, this process happens about 10 times in a row:

Installer step 1

Then I get this:

Installer 2

I have no options to choose from and no way of doing anything but downloading a 67mb file over and over again.

I've ran the log collection tool and found the following errors:

VisualStudio Bootstrapper:06/03/2018 22:54:48: Current Optin root path does not exists
VisualStudio Bootstrapper:06/03/2018 22:54:48: Commandline arguments = --env _SFX_CAB_EXE_PACKAGE:C:\Users\username\Downloads\vs_Community.exe _SFX_CAB_EXE_ORIGINALWORKINGDIR:C:\Users\username\Downloads
VisualStudio Bootstrapper:06/03/2018 22:54:48: Parent process name = vs_Community
VisualStudio Bootstrapper:06/03/2018 22:54:48: Parent process product version = 15.6.27428.1
VisualStudio Bootstrapper:06/03/2018 22:54:48: CampaignId = 
VisualStudio Bootstrapper:06/03/2018 22:54:49: DownloadURL = https://aka.ms/vs/15/release/installer
VisualStudio Bootstrapper:06/03/2018 22:54:49: InstallLocation = C:\Program Files (x86)\Microsoft Visual Studio\Installer
VisualStudio Bootstrapper:06/03/2018 22:54:49: OfflineFilePath = 
VisualStudio Bootstrapper:06/03/2018 22:54:49: LayoutLocation = 
VisualStudio Bootstrapper:06/03/2018 22:54:49: ExecutableArguments = /finalizeInstall install --in "C:\ProgramData\Microsoft\VisualStudio\Packages\_bootstrapper\vs_setup_bootstrapper_201803062254487844.json" --locale en-GB --activityId "2889c3b4-3927-44e8-8308-cc45702af3ed"
VisualStudio Bootstrapper:06/03/2018 22:54:49: OSVersion = Microsoft Windows NT 10.0.16299.0
VisualStudio Bootstrapper:06/03/2018 22:54:49: Starting to detect the existing VS and .Net...
VisualStudio Bootstrapper:06/03/2018 22:54:49: Finished detecting the existing VS and .Net
VisualStudio Bootstrapper:06/03/2018 22:54:52: Beginning file download. File = https://aka.ms/vs/15/release/installer.
VisualStudio Bootstrapper:06/03/2018 22:54:52: Download requested: https://aka.ms/vs/15/release/installer
VisualStudio Bootstrapper:06/03/2018 22:54:52: Attempting download 'https://aka.ms/vs/15/release/installer' using engine 'WebClient'
VisualStudio Bootstrapper:06/03/2018 22:54:52: Uri 'https://aka.ms/vs/15/release/installer' redirected to 'https://download.visualstudio.microsoft.com/download/pr/11711691/d68d54e233c956ff79799fdf63753c54/vs_installer.opc'
VisualStudio Bootstrapper:06/03/2018 22:55:02: Certificate is invalid: C:\ProgramData\Microsoft\VisualStudio\Packages\_bootstrapper\vs_installer\p.wlk\vs_installer.opc
VisualStudio Bootstrapper:06/03/2018 22:55:02: Caught Exception: Type = InvalidSignatureException, Message = Certificate is invalid: vs_installer.opc, StackTrace = 
VisualStudio Bootstrapper:06/03/2018 22:55:02: Certificate is invalid: vs_installer.opc
VisualStudio Bootstrapper:06/03/2018 22:55:02: Download failed using WebClient engine. Microsoft.VisualStudio.Setup.Security.InvalidSignatureException: Certificate is invalid: vs_installer.opc
   at Microsoft.VisualStudio.Setup.Download.DownloadManager.DownloadWithRetry(IDownloadEngine[] engines, Uri uri, Stream outputStream, ProgressUpdateCallback progress, CancellationToken cancellationToken, DownloadContext downloadContext, Boolean verifySignature)
VisualStudio Bootstrapper:06/03/2018 22:55:02: Sleeping 5000 milliseconds before retrying download.

I can't find a lot on this error. Most of it is Microsoft forums where people are told to "report a problem" but you can't do this for this error because it doesn't get that far into the installation process.

I have tried running the "offline installer" but all this does is launch the same process and fail over and over again. There doesn't seem to be much else that I can try.

I'm really not sure what else to do, does anyone have any ideas?!

  • You have a DNS issue. The error logs confirm that is the case. You should change your DNS provider to something other then you are currently using.
    – Ramhound
    Mar 10, 2018 at 15:50
  • I've just tried using OpenDNS, my ISP's DNS and Google's DNS (specified directly in my router). Then tried a hotspot using my phone's 4G and whatever DNS that has. Made no difference. Mar 10, 2018 at 16:00
  • Attempt to download this in your browser. If you cannot then (again) you have a DNS issue. It's possible provider or security software is blocking the download possible. Looks like the installer is ignoring the download due to a certificate error also ("Certificate is invalid"). Discontinue the use of any VPN or Proxy service you might be using.
    – Ramhound
    Mar 10, 2018 at 16:06
  • Yeah that downloads fine. i actually downloaded it previously because i was trying to manually specify that file with the installer. Still no luck. No VPNs or proxys in place - direct connection to my ISP and like I said I tried a 4g hotspot too to eliminate the possibility that it's to do with my internet connection. Mar 10, 2018 at 16:54

1 Answer 1


DNS issue? You clearly can discard that cause he was able to download the installer. If you actually read the log you would figure out and check what it says. Go to certmgr for your account, check in Trusted Root CA certificates and intermediate certificate and see if there is a Microsoft Certificate expired. I found out that my Microsoft Sig PCA was expired. I downloaded a valid one, installed and VS Installer was working perfectly.

  • It's OK I have upgrade to 2019 and have no issues with it. Aug 15, 2019 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.