I have a fresh, brand new installation of Debian 9.

After installation was completed, I installed the NVIDIA proprietary driver and everything worked fine.

The problem started when I tried to install Steam, because out of the box, it doesn't work on Debian 64 bit; I have to install some packages like:

apt install libgl1-nvidia-glx:i386

Which only works with:

dpkg --add-architecture i386

The problem is after that package is installed, because now I have some broken dependencies and I cannot use apt correctly, LibreOffice and Nvidia are uninstalled.

At the end, my whole system is broken and the only way for me to fix it is with a new fresh installation.

I have also tried aptitude and the problem is the same.

  • Unfortunately such problems are hard to solve using SO: they typically require you to cite the swaths of log output apt/aptitude produce, and then play Q&A session with folks who understand them. So I'd recommend to post a message to the debian-users mailing list instead.
    – kostix
    Mar 12, 2018 at 10:35

2 Answers 2


The problem is explained on the official documentation debian : Steam runtime issues.

Steam ships with its own versions of some libraries (the "Steam Runtime") in an attempt to emulate the Ubuntu 12.04 environment in later versions of Ubuntu.

However, some core libraries included in the Steam Runtime will often conflict with the newer versions of other libraries included in Debian (such as drivers, and specifically the open-source ATI driver).

To solve the problem :

remove offending files from Steam Runtime

# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6
# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1
# rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgpg-error.so.0

Restart your system.


You can use Gdebi.

gdebi installs a .deb package and its dependencies. To use it run:

sudo gdebi package.deb

You can install gdebi with this command:

sudo apt-get install gdebi

See man gdebi for a full list of options.

gdebi is the command line equivalent to the graphical tool of the same name , the command for the graphical tool is gdebi-gtk and has similar functionality:


  • I'm gonna try it, but the question is why do I have this problem, why apt or aptitude uninstall bunch of programs Mar 11, 2018 at 17:41
  • You're basically proposing to use a specific GUI front-end to do what # dpkg -i path/to/a/package.deb does; that does not address the stated problem in any way.
    – kostix
    Mar 12, 2018 at 10:33
  • gdebi could help to fix broken dependencies (this means solving the problem), check this link.
    – galoget
    Mar 12, 2018 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.