5

I was using a public computer on some public network and wanted to see how nslookup worked there. I tried set type=ns for some web-site and got this message:

DNS request timed out. timeout was 2 seconds.

Then I tried set ti=30 and some other lower numbers, but got the same message.

There is no such timeouts when I try the same things at home.

For what reasons might this message appear? How can I fix it?

6

DNS request timed out means NSLookup submitted the query to the DNS server, but did not get a response.

It's possible the DNS server you queried was having a problem and couldn't reply. Network errors could be to blame as well.

However, given that you did this from a "public computer," the most likely explanation is that your DNS lookup was blocked by the network's firewall. It's common for network administrators to require that DNS lookups originating from nodes on the internal network be done using approved DNS servers. These can either be DNS servers under the administrator's control, or specific public DNS servers selected by the admin.

Forcing clients to use DNS servers under the admin's control (or endure restricted or no ability to navigate the Internet) is commonly done for a variety of reasons:

  • To ensure LAN clients use the correct internal DNS servers, which may be necessary to ensure proper function of an internal DNS domain (e.g. Active Directory).

  • To prevent internal domain name information from being leaked to the Internet via lookups against public DNS servers (which are unencrypted).

  • To permit convenient logging of DNS requests made by all LAN clients.

  • To enable the admin to modify specific query results, for example when the admin wants to redirect a publicly-resolvable hostname to an internal private IP address (e.g. as an alternative to implementing hairpin NAT).

  • To inspect and potentially block certain lookups, such as those made by malware to its C&C servers.

How can I fix it?

The best course of action is to use the correct DNS servers. If the computer you used normally has Internet access, then the DNS servers it's configured to use by default are the correct ones.

Alternatively, if you can create a VPN connection from the machine, you could use that to tunnel DNS requests past the network firewall. Obviously you don't want to do this if it's against the acceptable-use policy for the machine you're using.

0

It would be many cases.

  1. You have limited access over the interent from network administrator.
  2. You are using bypass dns server which may be not responding try to flush and change from network properties. 3). Try to resolve with public dns 8.8.8.8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.