I just reinstalled my pfSense on scratch (previously on 2.2, now on 2.4). I’ve assigned the interfaces, configured an IP address and DHCP server for the LAN interface and opened the web configurator from a PC on the LAN network. I get the login page, but when I enter the default user and password, I just get the same login page again.

The pfSense beeps and on the console reports a successful login. The login page is the same as before, no error message or anything else.

If I try with an incorrect password, the login page displays Username or Password incorrect in the top bar and an authentication failure is logged on the console.

Browser is Firefox 58.0.2 on Ubuntu MATE 16.04 (64-bit).

What gives?

  • 1
    Have you tried another browser? Different computer? – Ultrasonic54321 Mar 13 '18 at 20:57
  • That was the next thing I tried, just waited for my work laptop to boot. With Firefox 58.0.2 on Windows 7 I was able to log in. Looks like a bug in the web UI. – user149408 Mar 13 '18 at 21:06
  • Odd… after restoring the config of my previous 2.2 setup, which forces the web GUI to HTTPS, I can login from the Linux system as well. I’m going to file a bug report. – user149408 Mar 13 '18 at 21:15
  • Glad to know you've solved your problem. – Ultrasonic54321 Mar 13 '18 at 21:16

This appears to be a bug in pfSense, which I have just submitted as #8368.

I was able to log in with Firefox 58.0.2 on a Windows 7 machine. After restoring my backed-up config from a 2.2.6 install, which requires HTTPS for webConfigurator access, I was able ti log in from the Linux machine as well.

Therefore, the following may help as a workaround:

  • Try a different browser or OS (or both), even just as a temporary measure.
  • Set a real password for the admin user and require HTTPS for webConsole.
  • This sounds like a client side issue, and not a pfsense issue. AKA why it was rejected as a bug – Tim_Stewart Mar 21 '18 at 22:19
  • @Tim_Stewart any clues to the source of the client side issue? I have no clue as to what client configuration could cause this behavior. – user149408 Mar 22 '18 at 12:29
  • I'm not sure, I have an installation with 2.4 and tried to reproduce it with what you described. I wasn't able to. – Tim_Stewart Mar 22 '18 at 18:07

Same issue.

  • Firefox 67.0
  • Ubuntu 18.04 LTS
  • pfSense 2.4.4-RELEASE-p3


I had logged in yesterday from this browser and desktop and it worked just fine the whole day. Other than running apt update && apt upgrade today, I hadn't touched anything else on the desktop since it was working and suddenly, it would no longer work today. I tried logging in with a Windows 10 laptop on Firefox and it worked just fine (Firefox 67.0; Windows 10 Home v1809).


I cleared the site's cookies and site data (Firefox > Page Info > Clear Cookies and Site Data), closed the browser, rebooted the desktop, and rebooted pfSense. It's now working like a charm again!

I saw your post on other forums and noticed others saying that it's a local issue. I have no idea what made it not work, but the above steps did something to help, so the fix may be as simple as something contained above.

The one thing I can confirm that it's not, at least in isolation, is something with the site cookies/data. Clearing that as outlined above and refreshing the page still did not resolve the issue.


If it happens again, I'll try rebooting only the router without rebooting the desktop and see if that does something. That'd likely confirm it's a router issue. If it doesn't fix it, maybe it's a desktop issue. Perhaps I could even try just restarting the desktop browser and see if it's a browser issue alone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.