14

I use PDF Split & Merge (PDF SAM) frequently, but don't want to set it as the default PDF handler.

When I right-click on a PDF and select Open with, these are the options I am given. To select PDF SAM I must click Choose another app and select PDF SAM there.

enter image description here

I would like for PDF SAM to be directly in the Open with menu.

I have looked over these questions for help:

I have modified the registry to set PDF SAM as the 2nd option in the OpenWithList:

enter image description here

But this does not appear to actually change anything.

I would be happy if Chrome, Edge, and Waterfox were simply not on that list of programs in the Open with menu, and I assume this would free up enough room for PDF SAM to graduate to the main list, but only Waterfox shows in the OpenWithList in the registry, and removing it does not appear to make any difference.

Update 1

Following the suggestions in the question linked in the comments (Manually Add Program to Open With in Windows 10) I tried DefaultProgramEditor and it failed utterly.

Then I opened the registry to HKCR.pdf\OpenWithProgids and removed the Waterfox entry from there, and this indeed removed Waterfox from the Open with list, but it did not add PDFSAM to that main list:

Registry:
enter image description here

Open with menu:
enter image description here

So, we've figured out how to remove unwanted entries from the primary list, but not how to add wanted entries to it.

I also found list similar question: Strange open with list (inconsistent with registry)

And checked to make sure that PDF SAM has both entries suggested by the answer there, and it does:
enter image description here

Update 2

A little bit after upgrading Windows 10 to build 1809 I noted PDF SAM is now showing in the Open With menu.

I have not tested yet to confirm that Microsoft has resolved this issue or if something else broke loose. Once I've confirmed this though, I'll write up an answer.

  • Not 100% sure, but I think it is a 2part edit and you have to edit/add to HKEY_CLASSES_ROOT\.pdf also. Check how the keys are added and I think you can figure it out – Narzard Mar 13 '18 at 21:14
  • Looks like they finally added context menus to allow this, but haven't tried it personally - superuser.com/questions/981962/… – panhandel Mar 13 '18 at 21:15
  • If you go to open with, pick PDF SAM in the "choose another app", and open the file, the next time you go to the open with menu for that filetype it should auto populate it with PDF SAM listed. I just tried this out by opening an image with IE via the open with menu and it populated the next time. Does this not work for you? I suppose not, since you are clearly a power users, but it is a curiosity that this isn't happening. – Dispenser Mar 20 '18 at 18:59
  • Yea, you could call me a Power User. Also, yea, the list does not change based on use. – music2myear Mar 20 '18 at 19:08
  • @music2myear Have you tried Default Programs Editor ? check it out and I assume that it has the exact feature that you need. – Ĭsααc tիε βöss Mar 21 '18 at 7:14
3

I had the exact same problem when I couldn't add Nitro Pro to the "Open with" Context Menu for *.pdf files. That's on Win7, but it doesn't look like if MS' approach to the feature has changed between both Operating Systems.

Trying out all kind of suggestions found online, I also gave NirSoft's OpenWithView a shot. (see http://www.nirsoft.net/utils/open_with_view.html ) This tool lists "all available applications in the 'Open With' dialog-box of Windows". Sure enough, it also listed Nitro Pro, but I became suspicious because the default icon of the tool wasn't displayed in the overview screen, whereas for all other programs it was. Next doublechecking the application's path (that's another column in the same overview), I found that it listed an old path, not the current one. (I had changed a folder name in the path at some point, an was surprized to find it back in this overview)

With yet another NirSoft tool, MUI Cacheview (see http://www.nirsoft.net/utils/muicache_view.html ), which allows to "view and edit the list of all MuiCache items on a system", I found that the MUIcache contained several values for Nitro Pro. Not only the most recent (and correct) one: somehow the obsolete name had also pertained. Apparently, this erroneous/obsolete value was the first one encountered and withheld by other applications, which could explain the abnormal behavior of the program.

As soon as OpenWithView displayed Nitro Pro correctly (i.e. correct path, also reflected by the tool's icon being shown), I was able to add it to the "Open With" list by following the steps indicated already: right click a pdf file >> Open with >> Choose another app (or "Choose another program..." in Win7). Next browse to the correct location, select the executable, and click "Open" button.

I'm not claiming that the same is happening in OP's case, as several elements of the "Open with" menu seem to behave bizarrely (see e.g. also this other post Strange open with list (inconsistent with registry) mentioned by OP), but it's not excluded either. The NirSoft tools are freeware AND portable, so OP could easily & quickly give the above a try.

1

Here is a workaround but it does work.

1) Select Open With and select Choose Another App

2) Select the App you want to add to the Open With list and click the Always open with this app radio button.

The app will now appear on the Open With context menu so if you do not want it to be the default app, go through the process again and select Adobe PDF Reader as the default app.

Windows registry has become a bit disorganized over the years and it is difficult to figure out what is going on. If you have the time, you could post before and after differences in your registry to see what Win 10 changed in this process.

  • This does not work. I set PDF SAM as the default handler the way your described and opened the Open With menu again and it was still not listed there. I set the default handler back to Reader and PDF SAM still does not show in the main Open With menu. – music2myear Mar 21 '18 at 20:24
  • @ music2myear Interesting. My Win10 is up to date and I just tried it to make sure it has those results. It does on mine. Does it show up while it is the default handler and disappear when you set Reader back? – Dan Sp. Mar 21 '18 at 23:45
  • Nope. It does not show up in the list at any point in these steps. – music2myear Mar 22 '18 at 15:23
0

For anyone that still has this problem, the solution would be going to

\HKEY_CLASSES_ROOT\Applications\"ProgramName.exe"\SupportedTypes

and add a new string containing the format you want to open e.g. ".mp4"

  • I'll check that out. – music2myear Feb 19 at 17:04
  • I've tried that but I didn't success. SupportedTypes is a key? What .mp4 should be? Another key? Would you please develop your answer in detail? – cdlvcdlv Mar 22 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.