0

I'm using a Dell Inspiron 7559, with a discrete nVidia Geforce 960M graphics card. I don't use wayland, but X.Org, and Gnome 3.

After installing nvidia propertiary drivers in Fedora 27, everything seems to be working fine aside from a couple of things:

  • Mouse seems to be "ghosting", leaving a small trail when you move it (similar to the old "mouse trail" effect from Windows 98)
  • When switching tabs in chrome, mouse seems to be leaving a noticeable bigger trail for a split second (the tab also takes that split second more to switch, compared to nouveau)
  • Sometimes the display "freezes" for a split second, without leaving any trail in the logs about why

I used this tutorial to install Nvidia drivers: https://rpmfusion.org/Howto/NVIDIA - so it's basically installing two packages from RPMFusion.

I also tried negativo17 repository (https://github.com/negativo17/nvidia-driver), but that also didn't help.

In general, nouveau works "fine", but not "great". I decided to give nvidia drivers a shot, and I noticed that most of the time, the desktop environment feels a lot smoother (like going from a 24fps video to a 60fps one).

Some additional info:

  • My BIOS doesn't allow me to select "hybrid" vs "discrete only" graphics card mode
  • I tried playing with "TearFree" options in X.org, but without any luck - perhaps I might be doing something wrong here, because my X.org only uses automatic configuration, I apply all changes using the xorg.conf.d directory
  • The driver version that gets installed through akmods is 390.25

Obviously, it's not going to be as easy as 'install the drivers and forget', but perhaps somebody know what other might I try to get nvidia drivers to work properly?

1

I had the same problem, although I use Arch Linux. The way I fixed it was to first disable and then re-enable PRIME Synchronization using xrandr:

To disable:

xrandr --output <output> --set "PRIME Synchronization" 0

And then to enable:

xrandr --output <output> --set "PRIME Synchronization" 1

Where is the name of my display. In my case, it's eDP-1-1 - you can find this out by looking at the output of xrandr --verbose

  • Thank you for that. I actually managed to find this out through experimenting and various old posts I've been able to find. Although it does help, it's not really a solution. I've made a script that triggers this for all displays upon login, which is an acceptable workaround for now, although not perfect. – samu Sep 24 '18 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.