0

After some use, Cygwin stops opening new shells when I try to open a new window or open a subshell in Midnight Commander (with ^o).

In MC it prints out:

Cannot open master side of pty: No such device or address (6)

Opening a new window fails with the window closing immediately.

To fix this, I have to exit all Cygwin windows and start again. Killing cygserver.exe or cygrunsrv.exe processes is sometimes also necessary.

This is happening for a long time now (at least a few months), but has increased in frequency and happens at least daily, sometimes every hour.

About my installation:

  • I'm using db_home: windows in /etc/nsswitch.conf
  • My terminal is fatty, a mintty clone with tabs. The issue seems to happen also with mintty.

Any idea what needs to be fixed?


EDIT: Found one more thing, when Cygwin stops to open new shells, it also fails to run __git_ps1 that I have in my PS1 prompt.

  • some BLODA interfering ? – matzeri Mar 14 '18 at 19:42
  • Don't think so, I have nothing in my system from that list and nothing I can think of that could interfere. I have a few things that like to interfere with some apps like te built-in windows antivirus, autohotkey, dropbox or teamviewer (with intergrations disabled) - but I doubt they are the case. Also, please note the edit in my question, @matzeri – Krzysztof Bociurko Mar 15 '18 at 10:52
  • It can be a failed race caused by AV. Difficult to say anyway without a reproducible way to recreate the issue. – matzeri Mar 17 '18 at 7:50
  • Any idea on how to debug when it happens on my machine? I might be able to find the cause, but have no idea on how to start, @matzeri. – Krzysztof Bociurko Mar 17 '18 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.