0

I always keep my laptop connected to my external monitor, with its lid closed, and put it on Sleep when not in use. Lately, I've noticed that, when waking the PC up from sleep, the external monitor is no longer the primary display but an extended one. If I open the laptop lid and close it again, the external monitor will go back to being the primary display - but having to do this each time is becoming annoying.

I am using Windows 10 and the latest graphics card & monitor drivers.

1

This might be caused by the monitor is disconnected while in the sleep.

When you disconnect the additional monitor, the original display settings are restored to your primary display. In addition, all open files and program windows are moved to the primary display.

Please check if latest proper graphic driver for your Windows available.

Reference: How can I stop windows re-positioning after waking from sleep?

  • Thanks! What I did was to delete the whole HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration, as suggested in one of the comments to the question you referenced. Seems to have worked. – z8080 Mar 22 '18 at 9:35
  • later edit: no it did not, this behaviour keeps coming back randomly.. – z8080 Apr 11 '18 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.