As a Brazilian, I want my american keyboard to use dead keys and to map cedilla (ç) to ' + c. The default mapping gives me ć. For GTK-based applications, this setup can be easily achieved by setting the following environment variable:

GTK_IM_MODULES=cedilla

However, for Qt-based applications (like KWrite), the same method doesn't work:

QT_IM_MODULES=cedilla #doesn't work!

The Qt applications will continue to print ć. How do I debug and fix this?

Note: please, do not suggest the approach given here. Typing AltGr + c feels very alien to a Brazilian and the GTK solution works just fine.

  • Dies the solution described in this post work for you, to set XMODIFIERS="@im=none" to let X11 handle dead keys. See also this Qt bug report. – harrymc Mar 17 at 20:18
  • Unfortunately, no – ivarec Mar 17 at 20:26
up vote 5 down vote accepted
+150

Creating a file ~/.XCompose with the following content should do the trick:

include "%S/en_US.UTF-8/Compose"
<dead_acute> <C>                        : "Ç"
<dead_acute> <c>                        : "ç"

However, this is working only if the application is reading the XCompose files (/usr/share/X11/locale/...). This is no X server setting but really depends on the application, see Gilles answer on UNIX.SE for a method to find out if an application is reading these files.

  • Amazing! Since I'm not using Wayland, this is good enough for me. – ivarec Mar 17 at 20:29

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.