0

I have two external screens plugged into my Windows 10 Surface, one via a dock. Windows knows that the two screens are identical, yet the maximum resolution is wildly different. Swapping the cables does not affect how Windows sets up the screens.

I've set up the displays to be identical in the past (it was fine yesterday) but I can't remember how and now one screen is a quarter of the size of the other.

How can I get Windows to set (and remember) the correct display settings?

Windows specifications:

Edition: Windows 10 Pro
Version: 1709
OS Build: 16299.309

The display driver was automatically updated to the latest version last night. I tried fiddling with the refresh rate as I think that's how I fixed it last time, but it made no difference this time.

Looking into the event viewer, it seems that Windows thinks the monitors are not just identical, but are in fact the same!

The working monitor (UID198195, but with the other UID mentioned as well):

Device DISPLAY\ACR0477\4&19637dbd&2&UID198195 was not migrated due to partial or ambiguous match.

Last Device Instance Id: DISPLAY\SECA706\4&19637dbd&0&UID206395
Class Guid: {4d36e96e-e325-11ce-bfc1-08002be10318}
Location Path: 
Migration Rank: 0xF000FFFF0000F100
Present: false
Status: 0xC0000719

The non-working monitor (UID206395 both times):

Device DISPLAY\ACR0477\4&19637dbd&2&UID206395 was not migrated due to partial or ambiguous match.

Last Device Instance Id: DISPLAY\SECA706\4&19637dbd&0&UID206395
Class Guid: {4d36e96e-e325-11ce-bfc1-08002be10318}
Location Path: ACPI(_SB_)#ACPI(PCI0)#ACPI(GFX0)#ACPI(DD09)
Migration Rank: 0xF000FFFF00000100
Present: false
Status: 0xC0000719

enter image description here

I've also discovered this in the registry. There appear to be four Acer monitors detected over time, all UID****95. -1981- & -2247- have Present: 1 and -2001- & -2063- have Present: 0. Does this mean "physically present"? Because the ones that have Present: 1 don't match the ones that are currently plugged in (-1981- & -2063-) as reported by Display Settings.

foo

UID198195

bar

UID206395

baz

4
  • It may be there is a hard limit on the number of pixels the GPU inside the computer can push. What is the model number of your computer? Or perhaps the GPU model? Mar 14, 2018 at 23:30
  • @music2myear And that changed yesterday?
    – CJ Dennis
    Mar 14, 2018 at 23:30
  • Oh, that was buried in the verbiage. I see that now. That's less likely to be the issue. Then you need to list what happened yesterday. Did your computer download/install updates? What build of Windows 10 are you running? Have you installed the latest drivers available? Mar 14, 2018 at 23:31
  • Where you are in the registry? If you want to check the monitors, you should go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\DISPLAY, your one is some migration key (kept by unknown reason, but not used). Also UID cannot be same, I'm using 3 monitors (same model), but UIDs are different.
    – uDev
    Mar 15, 2018 at 2:58

1 Answer 1

1

I downloaded the graphics driver from Intel and manually installed it via "Have disk" since installing a driver manually (run the .exe) is locked out by the operating system.

I tried adding a custom resolution in the Intel Control Panel the same as the monitor that works, but was told that the connection doesn't physically have the bandwidth to transfer that much data. So I swapped the monitor cables at the computer/dock side and it automatically detected the right settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.