I have moved to LibreOffice from Microsoft Office, basically because I refuse to pay the Price for Microsoft Office.

I like LibreOffice as it offers everything I need and does pretty much the same job as Microsoft Office.

I find though that it is no where near as fluent. I use Excel/Calc for keeping my website Stock up to date and upload it to my Site as a CSV.

I find when I am quickly trying to scan through the spreadsheet to find a particular product it has a massive lag and keeps freezing, where as in Excel I could scroll right through without any issues.

Is there something I should do in order to aid with the performance and combat this issue? I have noticed other issues, which are similar, such as saving, if I save a large document, it seems to save ok the first time but then if I make another change and need to save, it can take several minutes for the save to complete as the program stops responding, and on occasions it can stop responding for so long that I need to restart it.

I am now using Linux Mint but it was the exact same in Windows. I have around 1500 cells each using a VLookup.

Has anyone had similar issues and know any ways in order to make the performance slightly smoother?

I submitted an answer below which seemed to work but only for one day. As soon as I turned my computer on the next day it was back to the same old lag... The settings are all the same as they where when I ammended them.

Is there anything else I can try? or any other Office suites that might work better?

  • What operating system are you using? What version of LO? How big is your spreadsheet, and how complex is it (tons of formulas or mostly just data, how much complex formatting)? What file format are you saving it in (are you using files you originally created in Excel and are still .xls or .xlsx, or are the files .ods)? – fixer1234 Mar 16 '18 at 20:26
  • @fixer1234 I am now using Linux Mint but it was the exact same in Windows. I have around 1500 each using a VLookup. I think I may have solved the problem by increasing the memory allocated to Libreoffice and the Memory per object. Is it recommendable to do that? or is there something else I should maybe look at? – SupGen Mar 16 '18 at 20:30
  • I've never even looked at manually manipulating memory allocations. I can imagine that LO and MS Office use different tricks to make their products responsive, and that particular kinds of spreadsheets will be faster on one than the other. It isn't surprising that speed of rendering the page would be different. File saving speed could be affected by the need to translate file formats if you aren't using .ods (the native format). It would be helpful to update the question with the details in my first comment. (cont'd) – fixer1234 Mar 16 '18 at 20:42
  • If you've managed to solve the problem via memory allocations, please post an answer describing how to do it. That could be very useful to other readers. – fixer1234 Mar 16 '18 at 20:43
  • Bummer on your solution. Please add detail on the file format for context on the saving issue. Was this created in Excel and now you're using the file in LO? How much formatting does the sheet have? – fixer1234 Mar 18 '18 at 21:44

I have managed to solve my problem through ammending the Memory Allocations.

To do this I Chose the Tools tab and selected Options

within Options in the side menu I selected Memory

Under Graphics cache there are a few different options. I chose the top two Use for LibreOffice and Memory Per Object and increased the Memory Allocation for both.

Use for LibreOffice I changed to 128mb

Memory Per Object I changed to 20mb

This seemed to work for me. For other people, the memory you change it to may be different for better effects. I am going to have a play around with it to see if I can fine tune it further.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.