1

When I upload a file of a certain type with a Browse... button (<input type="file">) on a web page, the browser I'm using gets added to that file type's open with list. For example, if I do this:

I get this:

It also does that if I do the same thing with another browser, so it isn't specific to Chrome. For example, if I upload the zip file using Firefox, it will add Firefox to that list.

The problem is that if I try to open a zip file in a browser just like that by right-clicking on the zip file and doing Open with -> (name of browser), all it will do is download the zip file, which is useless since the zip file is already on my hard drive. For this reason, I don't want any browser showing up in the open with list for zip files (and there are also other file extensions such as docx that browsers can't open, so I don't want any browsers in their open with lists either).

I know that I can remove the browser from that list by going to the registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.zip\OpenWithList and removing the value corresponding to the browser, but if I do that and then upload another zip file using a browser, it will show up again. This means that each time I upload a file of a type that a browser can't open, I have to manually remove it through the registry, which is annoying.

So my question is, is there any way to tell Windows explicitly not to show a certain program in a certain file extension's open with list? Maybe add something to the registry? I've searched the web, but haven't found anything.

  • Perhaps the better question is why is the browser getting automatically added to the Open With list? I've uploaded my weight in Bitcoin of files and have never had this happen. – Twisty Impersonator Mar 17 '18 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.