7

I've got 2 wifi access points at both ends of my flat. So I got wifi in the whole flat. One of those access points is a router (TP-Link WR1043 v2) while the other one is just an access point (TP-Link WA901ND). Both have different ssids.

Now I've got 2 problems with this setup:

  1. There is a room which is exactly between those 2 access points. When I sit in this room it often switches between the 2 access points. This is okay when watching youtube videos, but it's annoying when playing games on my phone. It always causes a 2-3 second lag, sometimes even a disconnect.

  2. If I walk from one side of the flat to the other it takes like 10-20 seconds until my phone automatically switches into the other, nearer access point.

How can I solve those issues? I've already heard from something called "wifi roaming" related to this topic. What is it and can it help in this case?

10

Set both access points to the same network name (SSID).

Make sure both have the same network security settings, non-mixed, AES only, Same network keys, but on non-overlapping channels.

Set the fist router lan address to the lowest available address in the subnet. Example: 192.168.1.1 /24 Set DHCP accordingly.

Set the second router address to the highest in the subnet Example:192.168.1.254 /24 And turn off DHCP on this router. Make sure the second router is connected to one of the LAN ports of the first. (Router-1 lan ---> Router-2 lan)

On some model routers it will help to give the wireless client device a static IP address outside of the DHCP range.

If you can find roaming settings in your devices set them to high/aggressive.

That should be it. The wireless devices should automatically switch to the highest strength AP, Without dropping the connection.

Note: your milage will vary using real-time connections, Skype voip etc. There are better solutions to real-time traffic roaming.

9
  • I only got "11bgn mixed" and "11bg mixed" as "mixed" setting.
    – Florian
    Mar 23 '18 at 18:55
  • You can try it, and test roaming. I haven't had good experiences with mixed modes. You may have to make the n router fall back to b/g if it gives you issues. Or replace the one that only has b/g capability. I would test it out Mar 23 '18 at 18:57
  • It seems to work with mixed too. Even with normal roaming settings on my phone. Thanks! :)
    – Florian
    Mar 23 '18 at 20:20
  • 1
    "Set the second router address to the highest in the subnet Example:192.168.1.254 /24." This helped me!
    – Edwin Chua
    Apr 30 '19 at 13:35
  • 1
    @Tim_Stewart Thanks for the reply. I found the channel settings and with help of WiFi Analyzer on my smartphone I made sure that the channels do not overlap. (I already had all other settings in place.) Setting IP addresses and channels seems to be helpful as my smartphone switches between APs very fast, in about 10 seconds! So I guess I can neglect "mixed" and "AES" settings.
    – Pygmalion
    Feb 25 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.