0

I've made different .vbs files but I can't delete or make any changes to them, I just get a message:

You require permission from DOMAIN\user to make changes to this file

Where user is my own user.

What I've tried:

  • Starting in Safe Mode
  • Using Unlocker
  • Changing the files Security permissions - (I even gave Full Control to Everyone) *Deleting through CMD as admin (Access is denied)

-Windows 7 Ultimate


I tried this on a bunch of computers and was successfully able to "change" (delete, move, rename etc.) all the files, just not on this computer.


Edit: Results of running icalcs myfile.vbs

myfile.vbs NT AUTHORITY\SYSTEM:(I)(F)
           BUILTIN\Administrators:(I)(F)
           DOMAIN\myuser:(I)(F)
Successfully processed 1 files; Failed processing 0 files
  • Look for Local/Group Policy objects blocking access to VBS. Often done to mitigate Office/VBS Trojans; may be causing your problem. Check "Computer Configuration - Policies - Windows Settings - Security Settings - Software Restriction Policies" for one. – Ƭᴇcʜιᴇ007 Mar 19 '18 at 15:52
  • @Ƭᴇcʜιᴇ007 No Software Restriction Policies Defined – WELZ Mar 19 '18 at 16:04
  • Can you copy the file to the same directory using a different extension, then delete the copy? E.g. copy myfile.vbs myfile.txt then delete the .txt file – Twisty Impersonator Mar 20 '18 at 14:41
  • @TwistyImpersonator Yes. – WELZ Mar 20 '18 at 14:43
  • Then it's not a permission issue. Run Procmon and filter it to only watch for operations on your .VBS file, then try to delete it and see what's causing the failure. – Twisty Impersonator Mar 20 '18 at 14:45
0
  1. Run cmd as administrator
  2. Delete the files using the del command

If you need more simple steps, then just enable the administrator account, and then use that account to log in. Browse to the files you want to delete, and do it. Instructions on enabling administrator account are here: http://www.intowindows.com/enable-the-hidden-administrator-account-in-windows-10/

EDIT: If none of these work, try booting into another OS (e.g. from Linux, either from hard drive or portable USB) and deleting the files there

  • see updated answer – WELZ Mar 19 '18 at 14:20
  • @WELZ updated mine (I know it's hard, but it's all I got) – MythicalCode_ Mar 19 '18 at 14:24
  • My next plan was to do something similar to that, I was looking for a way to avoid it... to delete it (semi) traditionally. – WELZ Mar 19 '18 at 14:25
  • It's not necessary to use the built-in Administrator account to delete a file owned by a user and to which they have full control. It would be better to explain why the OP cannot delete a file he has full control over and offer a solution that addresses that specific problem. – Twisty Impersonator Mar 20 '18 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.