0

I've encountered a really weird problem at my home network. My current network is set up with just a single vlan, with all of my devices on it. The subnet is 10.0.0.x/24. But, I also have a set of static/public IP addresses (70.x.x.104-70.x.x.109) that I leased from Centurylink (my ISP), with 70.x.x.110 as the gateway for the static IPs. The 70.x.x.110 address was assigned specifically for my modem/router, and up to this point it has always worked to set up the servers that need static IPs with the correct IP address, a subnet of 255.255.255.248, and a gateway of 70.x.x.110 (public IP of the modem/router).

I've got a few servers in a rack that are being used as XenServer VM hosts. Those are all connected to a 48 port HP switch (V1910-48G). I don't have any special stuff set up on it, currently everything is on a single default VLAN on the switch, and the switch is connected directly to the gateway.

Ever since I created a new VM to host pfSense, I've been having problems getting static/public IPs to work on any of the VMs. I intended to set up pfSense on a separate VLAN, but forgot to switch the tag for the VM before I turned it on and installed it. It only had a single NIC on the VM, and I thought I had disabled routing/firewalling when I went through the initial configuration. However, ever since the install finished and pfSense booted up, any servers with static/public IP addresses are not able to ping/access anything on the network, including the gateway. There is no response at all when I try to ping the gateway (70.x.x.110). Even with the pfSense box shut down (which it has been ever since I saw the static IP issue), I'm still not able to either send or receive traffic on the VMs with static/public IPs.

All other network traffic works. I can access the internet successfully when I'm on the 10.0.0.x subnet, but I'm currently using the public IPs to host some game servers, and they are unavailable since they use the public IPs. I wasn't sure if this is an ARP issue or if routing configuration got changed somewhere - I don't know what all pfSense does upon install to change the network it is attached to.

I have factory reset both my modem/router (C2100T) and my switch, and cleared all DNS on a couple of Windows VMs that I was using to test the issue. Neither of those fixed the problem. Any ideas as to what could be happening?

  • You have not listed your VM technology, but I posit that your VM technology is creating a new virtual interface for the PFSense box - I imagine that this is not being bridged onto your LAN, and and that is your problem. Also, you mention "a single VLAN" on your post - why are you bothering with a VLAN ? – davidgo Mar 19 '18 at 21:19
  • I'm using XenServer as my virtualization host on my servers. It is creating a new virtual interface, and it appears to get correctly bridged to my LAN - pfSense worked correctly, and I was able to access it's web interface, but everything with a public IP stopped working once it was booted up. I referred to it as a VLAN because my switch sets it up as one - it refers to it as the default VLAN (VLAN 0001, in this case). – Joseph Mar 19 '18 at 21:31
0

It appears that a combination of the firewall on the router and the ARP cache was the issue. In the firewall options of the C2100T, there is supposed to be an option to disable or change the firewall for "public IP" addresses, but there was only the option to change the "private IP" firewall. I don't know how it could possibly be related, but after running the ARP cache clear on the router, the "public IP" option showed up in the firewall settings, and I was able to disable it, at which point the static/public IP addresses started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.