My Dad bought a GeForce 8800GT graphics card quite a long time ago now. It has never worked in his PC.

Print out from a dxdiag:

System Information
Time of this report: 4/13/2010, 19:52:40
Machine name: USER-PC   
Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.091208-0542)           
Language: English (Regional Setting: English)
System Manufacturer: To Be Filled By O.E.M.       
System Model: To Be Filled By O.E.M.               
BIOS: Default System BIOS          
Processor: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz (4 CPUs), ~2.3GHz             
Memory: 2046MB RAM          
Page File: 1045MB used, 3296MB available        
Windows Dir: C:\Windows    
DirectX Version: DirectX 10
DX Setup Parameters: Not found     
DxDiag Version: 6.00.6001.18000 32bit Unicode

DxDiag Notes
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
        Sound Tab 3: No problems found.
          Input Tab: No problems found.

DirectX Debug Levels
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

Display Devices
Card name: ATI Radeon HD 2400 PRO     
Manufacturer: ATI Technologies Inc.       
Chip type: ATI Radeon Graphics Processor (0x94C3)         
DAC type: Internal DAC(400MHz)       
Device Key: Enum\PCI\VEN_1002&DEV_94C3&SUBSYS_00000000&REV_00   
Display Memory: 1012 MB 
Dedicated Memory: 245 MB    
Shared Memory: 767 MB     
Current Mode: 1280 x 960 (32 bit) (75Hz)          
Monitor: Generic PnP Monitor      
Driver Name: atiumdag.dll,atiumdva.dat,atitmmxx.dll   
Driver Version: 7.14.0010.0523 (English)      
DDI Version: 10
Driver Attributes: Final Retail 
Driver Date/Size: 8/22/2007 02:43:14, 3021312 bytes

That info is from the current card that is installed in it and has been installed since its purchase roughly 3-4 years ago.

When I physically install the card I put it into a purple slot on the motherboard that the old card was in (if I go into the device manager and select properties on the current card it confirms that the slot is a "PCI Slot 16 (PCI bus 2, device 0, function 0)") and boot up the computer but get absolutely no output. The screen that we have registers that it is connected to something (by not displaying the screen it does when the cable is unplugged) but just remains blank, no output at all.

I recently took the card to my University and one of my friends who is better with hardware issues than I am tried it in his system and it worked perfectly. No issues whatsoever. I do not have a spec list for his system but I could get one if you need it.

If you need any more information on this issue I will be happy to supply you with it as I am starting to get very annoyed with this problem.

  • Motherboard problem? BIOS upgrade? – Apache May 15 '10 at 8:06

Do you have a VIA chipset on your motherboard?
Motherboards with VIA chipsets seem to be incompatible with the 8800GT.

If you don't know what chipset you have, download Everest Home and look under "motherboard" + "chipset".


Have you plugged the GeForce 8800GT's power connector in?

It's at the top of the back edge of the card. See the photo on this page - it's the first detailed photo.

enter image description here

On the top right hand corner of the videocard is a six pin PCI Express x16 power connector, don't forget to plug that in before powering on the system.

I know it might be stating the obvious, but these things can be overlooked especially if you're not used to graphics cards needing extra power.


Given that you have, is your PSU powerful enough to handle everything you've got hooked up?

Unplug everything you don't need (optical drive, second hard drive etc.) and see if it works then. If it does then you might need upgrade your PSU.

  • Yes, I have been plugging the power adapter in :) I did install it on my friend's computer at University and it all worked fine. – Samwho Apr 14 '10 at 15:19
  • @Samwho - I had to ask :) – ChrisF Apr 14 '10 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.