0

My colleague had a Windows 10 update come up a couple of weeks back for his Lenovo P50, which has a Nvidia M1000M graphics card. Since the update, his dual monitors (both identical) are running at different resolutions and can't be matched. The monitors have been working fine up until the W10 update.

On his docking station there are 3 sets of ports: VGA, a Display Port / HDMI combo, and a Display Port / DVI combo. When either monitor is plugged in using VGA, the resolution is correct, at 1920x1080. However when the same monitor is plugged in via HDMI or DVI, the max resolution is 1600x900. It can be changed to a lower resolution but it needs to be 1920x1080 to match the VGA connection.

We've tried plugging the HDMI into the laptop itself, but we get the 1600x900 resolution again. We've tried swapping the cables between the monitors but we're consistently getting the same result with VGA at 1920x1080 and the other ports at 1600x900. Tried updating the drivers in two different ways, using the windows driver search and the built in Lenovo system update (which updates hardware drivers). When that failed we tried deleting the driver and rebooting, but same thing is still occurring.

Does anyone have any ideas what else we can try? Am I right in thinking that the VGA isn't powered by the graphics card and would run off an Intel driver? Would that be the reason for the difference?

  • 1
    Could be a cable or adapter problem. However, since laptop has HDMI and DisplayPort you should avoid using VGA. – spike_66 Mar 21 '18 at 5:57
  • “The monitors have been working fine up until the W10 update.” I consider that if it could be related the update. After updating this update, some hardware vendors do not update the related files and may cause incompatibilities. Do you update the system version to the latest edition view ... – daidai Mar 22 '18 at 9:23
0

We never found the exact cause of this, but as a workaround we used the following solution. In the NVidia Graphics settings, there's an option to set a custom resolution. You have to manually enter the resolution you want, save it, then select it as the resolution you want, before applying it.

That's done the trick so far.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.