0

Apparently it's not possible to scroll (with the mouse wheel) while editing a formula. I'm using Microsoft Office Professional Plus 2016 (Version 1802).

My Research has revealed, that this was a problem after switching to Excel 2007. It must've worked before and did not work (the same way) in Excel 2007.

Unfortunately I do not know if this ever worked after that. A co-worker asked me about this and told me it used to work (a few weeks ago).

Is there any setting I'm missing? Is there a workaround?

What I've tried so far:

  • double-clicking in cell (to activate formula-editing mode) and trying to scroll
  • clicking in formula bar and trying to scroll
  • a combinational order of the above
  • while a cell is in focus, pressing F2 to activate editing mode and trying to scroll (apparently was a workaround back when 2007 was released)
  • middle clicking (scroll wheel) next to the cell I'm editing and using auto-scroll. This works!
  • Page Up and Page Down works. Arrow keys don't (they're already used to navigate through the formula).

I hope everything is clear. If not, please let me know so I can clarify and maybe add a screenshot. It should be possible, I guess. It'd be quite useful to actually see the range I'm working with.

  • Alex,, your research list is almost correct. While use option 2 & 3 scrolling is not possible, otherwise excel scrolls the sheet. I'm using both 2013 & 2016. – Rajesh S Mar 20 '18 at 10:52
  • If you have problem with scroll wheel then I can suggest you the solution. – Rajesh S Mar 20 '18 at 11:04
  • I knew I'd have a use for that Office 2003 install one day! I'll see if my old NT2000 box has it on to confirm if the formula bar scroll is locked or not. I can still scroll under your other conditions. Using Office 365 (Version 1708) on Win 10 (Version 10.0.16299) – Mark Fitzgerald Mar 20 '18 at 12:05
  • @MarkFitzgerald Thanks, that would be great! Please note that I am trying to scroll through the sheet (not the formula bar). – Alex Mar 20 '18 at 13:09
  • @RajeshS I'm sorry, I don't completely understand. What solution can you suggest? – Alex Mar 20 '18 at 13:09
0

They say a picture is worth a thousand words, but Superuser says I also need to have at least 30 characters: You won't be able to scroll if you click in the formula bar, but you should be able to if you edit in the cell.

enter image description here

  • Thanks. I played with that setting before. It was checked. It just doesn't want to scroll (the sheet). Any idea why it won't? – Alex Mar 20 '18 at 13:05
  • 1
    @Alex Here it scrolls the sheet if the cursor is in the cell; not if in the formula bar; not at all if that option is deselected. I don't know why yours is behaving differently – Ron Rosenfeld Mar 20 '18 at 13:50
0

This feature did indeed function perfectly well until it was broken in all versions post Office 2003.

The scroll feature works if you F2, Double-Click, Backspace, or start typing to edit within the cell, but will not work if you edit in the formula bar.

It can be fixed by installing the free to use X-Mouse Button Control.

My recommendation is to open Excel before you install, so that when you click Add, excel.exe is there in the list and easy to find:

Screenshot of "Choose Application" dialog

Then click on Settings and tick Make scroll wheel scroll window under cursor and Office is back to normal.

Screenshot of "Global Settings" dialog

protected by Community Aug 30 '18 at 20:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.