0

I have a Dell Latitude E5570 running Windows 7. There are three USB ports on the laptop (one on the right hand side and two on the back) and when I connect my keyboard and mouse to them they work fine.

However, when I attach the laptop to the Dell Dock (I think its the Dell Advanced E-Port 2) is when I get problems with the USB ports. The USB port on the side of the laptop works fine. The two on the back of the laptop stop working. None of the USB ports on the Dell Dock work.

I have two monitors attached to the dock and they work fine.

Odd thing is that they seem to work when the system is first powered up as the laptop is protected by some sort of device encryption (???) and I can type the password fine. I'm assuming this is a Windows issue.

0

For this my mouse and keyboard were plugged into the USB ports on the back of the dell dock (I used the laptops keyboard and touchpad to navigate).

First of all I found that Windows hadn't been updated in a while so I got all the updates. I'm not sure if this actually solved anything but is worth doing anyway.

Start > Control Panel > Windows Update

Once all updates had been installed I restarted my laptop. I then opened device manager

Start > Control Panel > Device Manager

In the Universal Serial Bus controllers section I could see the following entries

enter image description here

When I unplugged my mouse the device manager refreshed and one of the USB Composite Device entries disappeared. I then noticed that in the Other Devices section that there were several Unknown Devices with yellow warning triangles. I right clicked on one of the entries and selected Update Driver Software.

For whatever reason this worked! My mouse and keyboard are working through the dock.

My

  • 1
    Well Drivers are the first place to check for these type of issues. – C0deDaedalus Mar 21 '18 at 13:59
0

I had the same issue with a TB16 Dell Dock just now after some Windows Updates installed Dell drivers and firmware. Windows seems to be vague on the details. We are on a delayed WSUS, so not sure when these were released, if at all, officially.

Dell - Extension - 1.0.0.14
Dell - Extension - 1.3.2.178
Dell, Inc. - Firmware - 1.8.1

None of either the 3 USB 3.0 and 2 USB 2.0 ports worked. Display output wasn't affected.

The solution was to reinstall the Dell Thunderbolt Controller -- despite Dell's website telling me it was not meant for my service tag. Note that this is different than the Thunderbolt Driver. And the version linked will eventually be out of date.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.