1

I have created a topology as shown below using cisco packet tracer-

enter image description here

Here i have used a wireless router WRT300N. It has 4 LAN ports and each of them is connected to a computer. Each of the computer is assigned IP address as shown in the figure. This constitutes a subnet 192.168.2.0/24. And all the hosts in this subnet are assigned a default gateway as 192.168.2.1

And separately, i have created another subnet 192.168.1.0/24 using a switch, 2960-24TT. And i have connected 2 computers to that switch. Each of the computers in this subnet is assigned IP address as shown in the figure. And all the hosts in this subnet are assigned a default gateway as 192.168.1.1.

Please see below screenshot for the configuration done on the wireless router (WirelessRouter0)

enter image description here

enter image description here

Now with this configuration, if i try to ping 192.168.2.5 (subnet 2) from 192.168.1.2 (subnet 1), it is unsuccessful.

I think there is some problem with the configuration i have done on the wireless router. Could someone help me in correcting it and make it work?

And if you help in understanding the "Internet Setting" and "LAN setting" in the case of router with integrated switch, it would be of much use to understand the concept better.

PS: My understanding is, correct me if i have got it wrong- LAN Setting is to configure the router's interface to which the integrated switch would be connected. Whatever the subnet address i assign for this interface, should be the same for all the device which will be connected through the LAN ports?

Whereas WAN setting is to configure the router's another interface, to which another subnet can be connected. So whatever subnet IP address i assign for this interface should be same for all the device in that subnet? OR, Is it the public IP address for the router's other interface?

3

Update: Sorry, I had glossed over the fact you were doing all this in a network simulator (Cisco Packet Tracer). It looks like your simulator doesn't support the real settings that the Linksys WRT300N supports. The solution for you is to replace the incompletely-simulated WRT300N with something that can be configured as just a router, not a NAT gateway.

If you had a real WRT300N, you would need to disable NAT under the advanced router settings. For your setup, you need your router to be just a plain layer-3 IP router. That's a lot better than leaving NAT enabled and messing with a bunch of port forwarding rules. But since the Cisco Packet Tracer simulator doesn't simulate the WRT300N's ability to disable NAT and become a plain layer-3 IP router, this simulated object won't work for you in this role and you need to replace it with something that can act as a plain IP router without NAT.

Background info:
Most things that marketers or laymen call "wireless routers" or "home routers" aren't plain layer-3 IP routers by default. Instead, they are full-stack NAT (technically NAPT) gateways by default. NAPT gateways are asymmetric; they have one public IP address on the WAN side and they hide all their LAN-side clients behind that one public IP address. This keeps you from being able to reach LAN-side clients from the WAN side without creating special "port forwarding" rules (concepts that all basically come down to some flavor of port forwarding sometimes go by different names, such as "port mapping", "virtual servers", "trigger ports", DMZ, default host, bastion host, exposed host, ALGs, etc.).

| improve this answer | |
  • Could you please brief on the purpose of settings tabs under "LAN" and "INTERNET"? – Darshan L Mar 22 '18 at 2:42
  • I got your point. I am new for the networking world. I know a little bit about NAT. However, I am unable to find an option to disable NAT feature for the router on packet tracer. Your help would be appreciated. – Darshan L Mar 22 '18 at 18:30
  • 2
    @DarshanL Sorry, I had glossed over the fact that this was all being done in a simulator. I just checked out Cisco Packet Tracer's ability to simulate the WRT300N and discovered that it is incomplete. It doesn't let you disable the simulated-WRT300N's NAT feature; it doesn't even let you get to the "Advanced Routing" subtab of the "Setup" tab in the web GUI. You'll have to replace the WRT300N object with a different object that can act as a plain IP router, not a NAT gateway. – Spiff Mar 22 '18 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.