2

Heyo,

So I happen to have at least one CD - in this case, an Enhanced CD of Roger Sanchez's "Another Chance" - that I'm trying to make a backup of, but although I can seem to successfully back up both the audio and data sessions of the disc, trying to mount the data part has been... exhausting to say the least.

It seems to be a "hybrid" CD-ROM, in that it displays different content depending on whether I'm using a Mac or Windows PC (basically all the files shared by both partitions are in the same physical location, but the pointers for the file Apple users should see are slipped into the empty 32kB preceding the ISO magic number, that I understand).

When I insert the physical disc into my system, I can mount either "partition" without problem using either of the following:

  • sudo mount -t iso9660 /dev/sr0 /media/trolldecker/discimage0
  • sudo mount -t hfs /dev/sr0 /media/trolldecker/discimage0

However, after ripping the data session to an ISO image, mounting that image in the same manner produces completely different behaviour to the physical disc. Mounting as HFS works without fail. No problems there. Trying to mount it as ISO9660, on the other hand, initially appears to mount the thing, but the mounted image appears completely empty and bereft of any files whatsoever. Which makes no sense because the ISO9660 volume descriptor set is most certainly present in the ISO file (I checked with a hex editor).

I can't make sense of this issue and so far searching for answers takes me to results regarding hard drives and/or mounting on Mac OS. I've tried a few bizarre-but-might-have-worked ideas like blanking the HFS descriptor, but to no avail.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.