I am using a Huawei dongle with me. On my current kernel version, I have installed usb_modeswitch. As soon as I insert my Huawei dongle, it detects as mass storage instead of the modem. lsusb

Bus 001 Device 005: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard


  1. made DisableSwitching=1 in usb_modeswitch.conf file. this also doesn't work.

  2. Issued usb_modeswitch -v 0x12d1 -p 0x1506 -M "55534243123456780000000000000a11062000000000000100000000000000"

At this time it will work and my device get detects as the modem and I an able to get wwan0 interface along with that. But if I remove my dongle and insert it again, it again detects it as the storage device.

--> I want this to happen automatically, that no matter how many time I remove my dongle, it should always be get detected.

All these changes having below settings in kernel


Thanks, Ashish


After installing the latest version of usb_modeSwitch 2.5 its works fine.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.