1

On Windows 7 I had the following scheme of language settings:

interface: English US

default keyboard layout: Japanese IME

secondary keyboard layout: Russian

I failed in attempt to reproduce such settings on Windows 10: if I delete English from input languages, some of my apps change interface to Russian or Japanese automatically. I do not want to have three layouts (Eng, Rus, Jap), because – why to have separate Eng layout if Japanese also allows me to type in English?

I tried overriding display language in 'Advanced settings' of 'Control Panel\Clock, Language, and Region\Language' with English, but seems it has no effect if English is not on the language list.

If there is a method to exclude a layout from switching rotator (Alt + Shift / Ctrl + Shift / Win + Space) it would be a legit solution, I think.

To sum up, I want interface in English and just two layouts (jap, rus) in rotator (I do not want to use separate Key Sequences to switch them).

Is it possible on Windows 10?

2

Recently I've solved the same issue. Here is the translation for others who can face similar problem (sorry people for non-english language on the screenshots, but it is obvious what's shown there).

  1. In the RegEdit go to the HKEY_CURRENT_USER\Control Panel\International\User Profile key and find parameter with the value equal to the numeric keyboard layout you want to delete (refer here for the keyboard layout codes):

enter image description here

And delete this parameter. In my case I'm deleting the en-US keyboard with id 0409. If there will be a window in numeration of parameters after deletion restore the order. In my case I had to rename parameter 3 to 2.

  1. Go to the HKEY_CURRENT_USER\Control Panel\International\User Profile and find the subkey with the string name of the language where you want to delete keyboard layout (en-US in my case). Next, in this subkey, locate the REG_DWORD parameter named with the numeric id of the keyboard layout you are deleting:

enter image description here

And delete this parameter.

  1. Logoff and login again or reboot your computer. After these steps I've got the following:

enter image description here

enter image description here

enter image description here

On the login screen I have left the US keyboard layout, but in my user account it is absent. So, the problem was successfully solved :)

Hope this information will help others.

  • Thank you. It is very similar to what I did on Win 7, but for some reason I never assumed that might work on Win 10 too. Also it is worth mentioning, that some apps (like Word) may mess with fonts because of this. – John Doe Nov 17 '18 at 11:01
  • Could you tell which issues can be with fonts? I didn't saw them yet... – Alexander Pravdin Nov 18 '18 at 2:52
  • 1
    Sorry, it is not Word, but WordPad, that is affected. If you open WordPad and type something in Russian, it is OK, but if you switch to Japanese IME, the font switches to MS Mincho. You will have to switch back (to Calibri or Arial or anything else) manually. But it's not the fault of your method, it seems, it's a feature rather than a bug :) – John Doe Nov 18 '18 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.