0

I got some text (from here, fwiw, just the guitar tab part) When I copy/paste that text into TextEdit, the text is misaligned, as if it were not plain text, but I have selected Format > Make Plain Text.

I tried in in Win10/Notepad and it looks correct.

What am I doing wrong on the OS X side?

  • This feels like one of those unusual cases where screenshots for text would be helpful - that way folks without an OS X box on hand but have some idea of what's going on can help. Show us what both look like? – Journeyman Geek Mar 24 '18 at 1:05
3

I'd guess that TextEdit doesn't use a monospace font by default. Tab files rely on predictable spacing, and monospaced fonts (fonts where each character gets exactly the same space as every other character) allow this.

Notepad defaults to using a monospaced font (though you can change that, and then it would probably have the same problem as TextEdit is).

I am not familiar with TextEdit, but I would look through its settings either for a Monospace setting, or for font selection, and then find and select a monospaced font.

  • Doing a search on OS X monospace fonts, it lists a few. I've tried some and its very close. But not quite there. Hmph. – Al Lelopath Mar 23 '18 at 23:39
  • It looks fine for me in TextEdit (in macOS 10.12) in any of the fixed-with (monospace) fonts -- and Format > Make Plain Text should switch it to fixed-width. Try Format menu > Font > Show Fonts, then in the Fonts window's Collection column, select Fixed Width, then in the Family column select anything other than "Apple Color Emoji" (which isn't actually fixed-width). – Gordon Davisson Mar 25 '18 at 5:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.