8

I have a big problem with my Oracle VirtualBox (see error below). It simply doesen't work anymore - I've tried all the stuff which can be found on Google. My system is Windows 10 on a Dell Latitute (newest generation). I am not able to start any kind of virtual mashine out of my VirtualBox. Everytime I try it the following error occurs:

VirtualBox - Error In supR3HardenedWinReSpawn (rc=-5640) Please try reinstalling VirtualBox. where: supR3HardenedWinReSpawn what: 1 VERR_SUP_VP_THREAD_NOT_ALONE (-5640) - Process Verification Failure: The process has more than one thread.

screenshot here

Does anyone know what to do in this case (except for resetting up the whole pc)? I already tried multiple times to reinstall VB (in version 5.2.6 and 5.2.8), reinstalled and started the VBoxDrv-Service and even updated my BIOS... Nothing happend...

If I forgot something just ask, thank you and kind regards

10 Answers 10

15

You can try this, (it worked for me):

  1. Navigate to C:\Program Files\Oracle\VirtualBox\drivers\vboxdrv
  2. Right click on VBoxDrv.inf file and select Install option
  3. Open the Console as administrator and run the following command: sc start vboxdrv

(source)

| improve this answer | |
  • Thanks! It worked. – soachishti Feb 28 at 19:41
3

First I realized a directory problem with VirtualBox driver. A solution is proposed in StackOveflow by Allan T. https://stackoverflow.com/questions/27082252/virtualbox-cannot-access-the-kernel-driver

  1. Close VirtualBox
  2. Open regedit.exe from the Start Menu(windows key+R and search for regedit)
  3. Navigate to HKEY_LOCAL_MACHINE\system\currentcontrolset\services\vboxdrv
  4. Double click on ImagePath
  5. If the path is \C:\Program Files\Oracle\VirtualBox\drivers\vboxdrv\VBoxDrv.sys then there is no directory problem
  6. Otherwise, change the value of the path to \C:\Program Files\Oracle\VirtualBox\drivers\vboxdrv\VBoxDrv.sys

After solving the directory problems as indicated above,

  1. Manually run the VBoxDrv.inf file located at C:\Program Files\Oracle\VirtualBox\drivers\vboxdrv
  2. Run sc start vboxdrv in command prompt with administrator privilege

Hope your problem is solved!

| improve this answer | |
2

Just change the ParaVirtualization Interface to other than Default and it should work then. I chose KVM and my VM just started fine.

| improve this answer | |
1

This worked 100% for me.

  • Remove your OS Configuration (In my case Ubuntu), by just clicking Remove Only.

  • Then create a new Configuration with the same image.

  • Now it should work well.

  • Else increase or decrease a little amount of ram, Now it should work fine.

| improve this answer | |
0

Just increase the RAM size from virtual box settings

Right Click on OS image . Settings->System->MotherBoard Increase the base memory

You should be fine.

| improve this answer | |
0

I have a different error but reached to this post. The error message is "where: supR3HardenedWinReSpawn what:5; VERR_INVALID_NAME(-104) - Invalid (malformed) file/path name." The VBoxHardening.log says it has error opening this file: "c:\WINDOWS\system32\wintab32.dll".

It happened after installation of the Trusteer Endpoint Protection offered by IBM. So my solution was to have the software removed. Hope this will be helpful for others.

| improve this answer | |
0

There are lots of reasons why you might get this problem, and I am not downvoting anyone's solution because it didn't work for me. (None of them did.) What worked for me was to reboot, uninstall VirtualBox, reboot, and reinstall VirtualBox. If my solution doesn't work for you and none of the other solutions do either, I'd suggest consulting Diagnosing VirtualBox Hardening Issues.

| improve this answer | |
  • For me just Windows restart was enough – piotr_cz Sep 16 '19 at 14:55
-1

My Case. It is problem that PC BIOS and virtual box driver (Window 10 64bit). I do change value form 0x00000001 to 0x00000003 in regedit vboxdrv "start" option. Next pc restart and vboxdrv restart (DOS prompt: sc start vboxdrv ). Now I can use virtual box.

Detailed solution is:

  1. Close VirtualBox
  2. Open regedit.exe from the Start Menu(windows key+R and search for regedit) Navigate to HKEY_LOCAL_MACHINE\system\currentcontrolset\services\vboxdrv
  3. Double click on Start
  4. vlaue change form 0x00000001 to 0x00000003
  5. PC restart
  6. Run sc start vboxdrv in command prompt with administrator privilege.
| improve this answer | |
-1

i got the same issue with virtualbox version 6.0.0 . the workaround for this is use headless start which is below the start option it worked for me.

| improve this answer | |
  • 1
    Can you go into a little more detail on how to start the VirtualBox in headless mode? – Burgi Mar 7 '19 at 15:49
  • To start a VirtualBox in headless mode, look for the tiny black triangle to the right of the big green "Start" arrow. That tiny triangle is a dropdown menu with three options, "Normal Start", "Headless Start", and "Detachable Start". Presumably, selecting the second option will start the VirtualBox in headless mode, but I haven't tried it and am not sure what it does. – JPaget Sep 7 '19 at 3:13
-2

I uninstalled a Antivirus software and that it. I have had to roll back, disable the AV and reinstall the update of vm. https://forums.virtualbox.org/viewtopic.php?f=6&t=88305

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.