0

I just re-install windows 8.1 then I've installed Windows8.1-KB2939087-x64, Windows8.1-KB2975061-x64, Windows8.1-KB2919355-x64, Visual C++ Redistributable for Visual Studio 2015 and Google Chrome. At that point everything worked normally except that the monitor identified as #2 in the picture below displayed the full HD (1920x1080) improperly.

To fix that I downloaded the Graphics driver for my APU processor with graphics (AMD Fusion APU A4-5000 Quad-Core with AMD Radeon HD8330 Graphics). That's when the second display went haywire and displayed everything in grayscale (though now 1920x1080 takes the entire screen unlike before)

Here is what I get: color screen against grayscale screen I had to photoshop it to grayscale to show you what it looks like because when I take a snapshot of the desktop (print screen) the picture is in full color.

I've also tried to reset my monitor; nothing changes. Also when I boot to windows 10 the color is back again which means this comes from windows 8.1 somehow.

6
  • If the screen shot is in color, then a color image is being sent to the display. Check your cable connections and consider replacing the video cable to the monitor. Mar 24 '18 at 16:20
  • @Twisty Impersonator like I said when I boot to windows 10 both monitors are in color which means it can't be the cable or the monitor.
    – Paiku Han
    Mar 24 '18 at 16:27
  • indeed ... I missed that, however we must still say Windows is sending a color image. What happens if you switch the video cables of your two displays? Mar 24 '18 at 16:28
  • I can't. One is vga the other hdmi
    – Paiku Han
    Mar 24 '18 at 16:37
  • Let me guess, the greyscale monitor is the VGA one? Mar 24 '18 at 16:39
0

This has happened to me on occasion as well. Check for a grayscale filter being applied.

  1. Right click on desktop and choose Personalize
  2. Click Themes on the left bar and then choose 'High Contrast Settings` on the right side.
  3. There will be a slider called apply color filter. Make sure it is off. Reference image: https://i.imgur.com/v8cauHU.png

The same menu can also be accessed from control pane > ease of access.

0

Problem solved by uninstalling the latest graphics driver and installing an older driver

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.