3

I inherited a Toshiba laptop with a failed HDD. This has Windows10 installed on it, but seems to be unrepairable, although I can boot from a Ubuntu 16.04 USB.

I want to try and resurrect it, and have downloaded Win10_1709_EnglishInternational_x64.iso and attempted to make a bootable USB.

I tried (on macOS) hdiutil convert -format UDRW as suggested in one post and used dd to write to USB, and this looks OK. The original image appears to be UDF format.

I tried formatting the USB as FAT32, but could not copy the contents of the disk (as one directory was too big).

I tried formatting the USB as EXFAT, copied the contents of the disk, but this failed to boot.

There are a few tutorials which suggest bootcamp to create a bootable USB, but this doesn't seem to be possible on High Sierra.

Can anyone suggest a method of making a Windows 10 install USB on Ubuntu 16.04 or macOS 10.13


EDIT
I seem to be caught in a Catch22 situation. I need EFI on a FAT partition (but apparently not ExFAT) to boot. Unfortunately I cannot copy Windows to FAT32 because one of the files is too large.

Other bootable USB seem to have a small EFI partition with a system in another, but I am at a loss how to achieve this.


EDIT 2 I tried a new approach.

I created a 500mB FAT32 partition and set the boot and esp flags, and copied the efi directory from the Windows install disk.

I copied the contents of Windows install disk to a NTFS partition.

This appeared to help, resulted in errors"-

"Your PC/Device needs to be repaired … You'll need to use recovery tools"

  • windowscentral.com/… doesn't work for you? – Mike 'Pomax' Kamermans Mar 25 '18 at 4:37
  • @Mike'Pomax'Kamermans Unfortunately as I said "but this doesn't seem to be possible on High Sierra" because the "Create a Windows 7 or later version install disk" option no longer exists, – Milliways Mar 25 '18 at 6:50
  • and apple.stackexchange.com/a/199427 didn't fix that problem either? How many other computers do you have and are any of them win10 to just take the toshiba hd, plug in, and fix? – Mike 'Pomax' Kamermans Mar 25 '18 at 16:19
  • ESP must be a FAT16/32 partition although some odd manufacturers allow other filesystems such as exFAT – phuclv Mar 25 '20 at 3:49
2

This guide has an excellent walkthrough of how to create a Windows iso image from MacOS. After mounting the image you need to use a tool called wimlib that can split the .wim file that's over 4GB and copy it to the image drive. From the tutorial:

... you can split the install.wim file as follows:

wimlib-imagex split /Volumes/CCCOMA_X64FRE_EN-US_DV9/sources/install.wim /Volumes/WINDOWS10/sources/install.swm 4000

The 4000 means the file should be split into 4000 MB-sized chunks (which is slightly less than 4 GB).

  • Creation of the USB worked for me, but then the windows installer showed an error that it can't open the C:/sources/install.wim :( – Tomor Jun 17 '20 at 19:48
0

You can have windows create the USB media for you. - https://www.microsoft.com/en-us/download/details.aspx?id=56485

Or using the ISO I prefer YUMI UEFI (Windows is at the bottom of choices) Using YUMI you can have windows and Ubuntu on one stick. It's pretty straight forward.

  • 3
    Unfortunately NOT if you don't have a working Windows system. – Milliways Mar 25 '18 at 0:43
  • It "Might" run in Wine, there is also links to Linux installers on YUMIs site. – Sir_Scofferoff Mar 25 '18 at 0:54
0

I know that this question isn't in right section, but I suggest to you. For EFI boot you just need to do following steps:

  1. Format USB flash drive in FAT32.
  2. Mount Windows 10 iso.
  3. Copy all files from Windows 10 iso to USB flash drive.
  4. That's all.

EFI no needs special boot sectors. All that need is FAT32 partition and \efi\boot\boot[arch].efi loader.

Move that questions to serverfault, for instance.

  • 5
    So I guess sources/install.wim didn't exceed the 4 GiB FAT32 file-size limit back in 2018? The one I'm looking at is 4.3 GiB :( – genpfault Oct 27 '19 at 14:34
0

For those still looking for a solution, if you have wimlib-imagex installed, you can reduce the size of install.wim to less than 4GB by doing:

wimlib-imagex optimize install.wim --solid

and it should then be small enough to copy over. (As of Jan. 2021: it went from 4.9G -> 3.7G. It does take a little while to complete.)

"install.wim" original size: 5178206 KiB
Using LZMS compression with 16 threads
Archiving file data: 10 GiB of 10 GiB (100%) done
Calculating integrity table for WIM: 3786 MiB of 3786 MiB (100%) done
"install.wim" optimized size: 3877659 KiB
Space saved: 1300547 KiB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.