0

My issue is very similar to the one asked in that question: Windows Service SearchIndexer.exe Crashes on Indexing , however the asker there seems to have abandoned it, hence the repost by me.

Basically, when I check windows error report, I see Windows Indexing crash every 5 minutes. I'm also unable to search my mail in Outlook 2013. I found out about it since wermgr.exe was regularly stealing focus from other applications.

Details of the crash from Event Viewer:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2018-03-26T07:35:20.000000000Z" /> 
  <EventRecordID>122369</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>my.host.name</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>SearchIndexer.exe</Data> 
  <Data>7.0.7601.23930</Data> 
  <Data>59deb9ab</Data> 
  <Data>KERNELBASE.dll</Data> 
  <Data>6.1.7601.23915</Data> 
  <Data>59b94f2a</Data> 
  <Data>c0000005</Data> 
  <Data>000000000000ca53</Data> 
  <Data>484</Data> 
  <Data>01d3c4d4fd3f0697</Data> 
  <Data>C:\Windows\system32\SearchIndexer.exe</Data> 
  <Data>C:\Windows\system32\KERNELBASE.dll</Data> 
  <Data>3bfd5da3-30c8-11e8-bdaf-c85b760b9951</Data> 
  </EventData>
  </Event>

I followed instructions by magicandre1981 from the other thread and got a crash dump, summary below. In case the full dump is needed, I can upload it somewhere.

Dump Summary
------------
Dump File:  SearchIndexer.exe.1156.dmp : C:\Localdumps\SearchIndexer.exe.1156.dmp
Last Write Time:    26/03/2018 09:35:23
Process Name:   SearchIndexer.exe : C:\Windows\System32\SearchIndexer.exe
Process Architecture:   x64
Exception Code: 0xC0000005
Exception Information:  The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information:   Present

System Information
------------------
OS Version: 6.1.7601
CLR Version(s): 

Modules
-------
Module Name Module Path Module Version
----------- ----------- --------------
SearchIndexer.exe   C:\Windows\System32\SearchIndexer.exe   7.0.7601.23930
ntdll.dll   C:\Windows\System32\ntdll.dll   6.1.7601.23915
verifier.dll    C:\Windows\System32\verifier.dll    6.1.7600.16385
kernel32.dll    C:\Windows\System32\kernel32.dll    6.1.7601.23915
KERNELBASE.dll  C:\Windows\System32\KERNELBASE.dll  6.1.7601.23915
sysfer.dll  C:\Windows\System32\sysfer.dll  12.1.7004.6500
advapi32.dll    C:\Windows\System32\advapi32.dll    6.1.7601.23915
msvcrt.dll  C:\Windows\System32\msvcrt.dll  7.0.7601.17744
sechost.dll C:\Windows\System32\sechost.dll 6.1.7600.16385
rpcrt4.dll  C:\Windows\System32\rpcrt4.dll  6.1.7601.23915
user32.dll  C:\Windows\System32\user32.dll  6.1.7601.23594
gdi32.dll   C:\Windows\System32\gdi32.dll   6.1.7601.23914
lpk.dll C:\Windows\System32\lpk.dll 6.1.7601.23930
usp10.dll   C:\Windows\System32\usp10.dll   1.626.7601.23894
ole32.dll   C:\Windows\System32\ole32.dll   6.1.7601.23889
oleaut32.dll    C:\Windows\System32\oleaut32.dll    6.1.7601.23775
tquery.dll  C:\Windows\System32\tquery.dll  7.0.7601.23930
shlwapi.dll C:\Windows\System32\shlwapi.dll 6.1.7601.17514
mssrch.dll  C:\Windows\System32\mssrch.dll  7.0.7601.23930
esent.dll   C:\Windows\System32\esent.dll   6.1.7601.17514
imm32.dll   C:\Windows\System32\imm32.dll   6.1.7600.16385
msctf.dll   C:\Windows\System32\msctf.dll   6.1.7601.23915
psapi.dll   C:\Windows\System32\psapi.dll   6.1.7600.16385
shell32.dll C:\Windows\System32\shell32.dll 6.1.7601.23893
profapi.dll C:\Windows\System32\profapi.dll 6.1.7600.16385
CRYPTBASE.dll   C:\Windows\System32\CRYPTBASE.dll   6.1.7601.23915
secur32.dll C:\Windows\System32\secur32.dll 6.1.7601.23915
sspicli.dll C:\Windows\System32\sspicli.dll 6.1.7601.23915
credssp.dll C:\Windows\System32\credssp.dll 6.1.7601.23915
clbcatq.dll C:\Windows\System32\clbcatq.dll 2001.12.8530.16385
msidle.dll  C:\Windows\System32\msidle.dll  6.1.7600.16385
cryptsp.dll C:\Windows\System32\cryptsp.dll 6.1.7601.23471
rsaenh.dll  C:\Windows\System32\rsaenh.dll  6.1.7600.16385
RpcRtRemote.dll C:\Windows\System32\RpcRtRemote.dll 6.1.7601.17514
mssprxy.dll C:\Windows\System32\mssprxy.dll 7.0.7601.23930
propsys.dll C:\Windows\System32\propsys.dll 7.0.7601.17514
ntmarta.dll C:\Windows\System32\ntmarta.dll 6.1.7600.16385
Wldap32.dll C:\Windows\System32\Wldap32.dll 6.1.7601.23889
vssapi.dll  C:\Windows\System32\vssapi.dll  6.1.7601.17514
atl.dll C:\Windows\System32\atl.dll 3.5.2284.0
vsstrace.dll    C:\Windows\System32\vsstrace.dll    6.1.7600.16385
samcli.dll  C:\Windows\System32\samcli.dll  6.1.7601.17514
samlib.dll  C:\Windows\System32\samlib.dll  6.1.7601.23677
netutils.dll    C:\Windows\System32\netutils.dll    6.1.7601.17514
es.dll  C:\Windows\System32\es.dll  2001.12.8530.16385
apphelp.dll C:\Windows\System32\apphelp.dll 6.1.7601.17514
cfgmgr32.dll    C:\Windows\System32\cfgmgr32.dll    6.1.7601.17514
wtsapi32.dll    C:\Windows\System32\wtsapi32.dll    6.1.7600.16385
winsta.dll  C:\Windows\System32\winsta.dll  6.1.7601.18540
userenv.dll C:\Windows\System32\userenv.dll 6.1.7601.17514
sxs.dll C:\Windows\System32\sxs.dll 6.1.7601.17514
Query.dll   C:\Windows\System32\Query.dll   6.1.7601.23930
ELSCore.dll C:\Windows\System32\ELSCore.dll 6.1.7600.16385
elslad.dll  C:\Windows\System32\elslad.dll  6.1.7600.16385
NaturalLanguage6.dll    C:\Windows\System32\NaturalLanguage6.dll    6.1.7601.17514
crypt32.dll C:\Windows\System32\crypt32.dll 6.1.7601.23769
msasn1.dll  C:\Windows\System32\msasn1.dll  6.1.7601.17514
NLSData0007.dll C:\Windows\System32\NLSData0007.dll 6.1.7600.16385
NLSLexicons0007.dll C:\Windows\System32\NLSLexicons0007.dll 6.1.7600.16385
NLSData0009.dll C:\Windows\System32\NLSData0009.dll 6.1.7600.16385
NLSLexicons0009.dll C:\Windows\System32\NLSLexicons0009.dll 6.1.7600.16385
NLSData0018.dll C:\Windows\System32\NLSData0018.dll 6.1.7600.16385
NLSLexicons0018.dll C:\Windows\System32\NLSLexicons0018.dll 6.1.7600.16385
  • Can you schedule a disk check on that device and see if it finds any permissions issues? It looks like there's a problem with FS perms. Are there any custom policies in use on the machine, and is this part of a network or stand alone? – Alex Mar 26 '18 at 10:28
  • This is a networked corporate-provided device, with (probably) plenty of policies set by the domain admins. Our team has local admin rights on our machines, but none of my colleagues have the same problem. This leads me to believe the problem's not caused by the domain policies, but I probably caused it somehow instead. What kind of a disk check do you have in mind? – Zaroth Mar 26 '18 at 11:02
  • The disk check would just be a standard windows disk check (from properties on the disks right-click context menu in Windows Explorer). The log data doesn't show which resource the permissions check failed on, so it's difficult to pinpoint exactly, but my first guess would be a file system issue, or possibly an Outlook issue. Search indexing should run as an elevated process, so it should have permissions on the entire disk. A reinstall of outlook might be worth a try in this case. – Alex Mar 26 '18 at 11:10
  • open the ump in windbg and run !analyze -v, do you see the same output? – magicandre1981 Mar 26 '18 at 14:13
  • I tried to run chkdsk, no improvement. I also tried going into properties of the hard drive and first unchecking the option "allow indexing" and then checking it again to make sure all files are properly marked. No change again. Here's the Windbg output, too big to paste it here on stackoverflow imho: pastebin.com/6Mc7zVEY – Zaroth Mar 27 '18 at 7:16
1

Alright, so I solved my problem. However, I have no real confidence in that the last step was what truly helped my case, so I'll list all the steps I did in order to get it working again.

  • I tried to rebuild search index - didn't help
  • Installed Intel Rapid Storage driver - no change
  • Ran chkdsk on both hard drives - didn't help
  • Unchecked the box to permit indexing on C: drive and subdirectories, and then checked it again - didn't help
  • Removed from indexing options in control panel every entry but "Microsoft Outlook" and "Favorites" and then rebuilt the index again - seemed to somewhat help for a moment, but stopped working again promptly (no search in Outlook, but also the error reports stopped coming)
  • Disabled Cached Exchange Mode for my account in Outlook - search seems to work again, not breaking for one day straight now.

Not sure if this is helpful to future visitors, since I didn't identify the root cause, but as of now the Outlook search is working and I'm satisfied. Thanks for all the suggestions in the comments.

  • thanks for posting your solution. Maybe this helps other users. – magicandre1981 Mar 28 '18 at 15:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.