3

I'm trying to run AMD Radeon RX580 (Sapphire brand, 8GB memory) on Windows 10 (64-bit) Hyper-V Guest using this instruction:

  1. Install GPU drivers to host
  2. Add Gen 1 VM to Hyper V (Server 2016 / Windows 10)
  3. Do not use Dynamic Memory
  4. Set properties of VM in hyperV to shut down when host shuts down
  5. Find GPU in device manager go to properties and get the "location path" detail. Will look similar to this but longer PCIROOT(0)#PCI(0200)
  6. Run below command on Hyper V host Dismount-VmHostAssignableDevice -locationpath "PCI-Location-path" -force
  7. Add-VMAssignableDevice -LocationPath "PCI-Location-path" -VMName "name-of-VM"
  8. Run this command (remember to set the -HighMemoryMappedIoSpace to the maximum of your GPU VRAM)
  9. Set-VM "name-of-your-VM" -GuestControlledCacheTypes $True -LowMemoryMappedIoSpace 2000MB -HighMemoryMappedIoSpace 8000MB

I have tried to install there drivers:

  • whql-win10-64bit-radeon-software-crimson-relive-17.4.3-apr17.exe
  • win10-64bit-radeon-software-adrenalin-edition-18.3.3-march18.exe

But both failed to work with Windows 10 Hyper-V guest. What could be missing?

enter image description here

3

Today I need to share GPU from Windows 10 with Hyper-V with a Virtual Machine that contains an Windows 7 with Graphical Software, I use only the PowerShell Command at this tutorial (in link bellow) and appeared at VM Setting the rule Remote Fx (with that feature, is possible to calibrate the dedicated GPU):

1-Open Windows Powershell as Administrator mode;

2-Check if the Physical GPU is visible by Hyper-V service:

Get-VMRemoteFXPhysicalVideoAdapter

3-Enable your Physical GPU for with Hyper-V service (at this example, my GPU Card name starts with "NVIDIA"):

Get-VMRemoteFXPhysicalVideoAdapter -Name *Nvidia* | Enable-VMRemoteFXPhysicalVideoAdapter

4-Associate VmRemoteFx enabled before to your VM (this needed to be turned off):

Add-VMRemoteFx3dVideoAdapter -VMName [Windows7-DEV]

View my Windows7 Settings dialog with RemoteFx feature added

Tutorial followed: HyperV “GPU RemoteFX 3D Video adapter” gone in Windows 2019 Hyper V

1
-3

Use the driver for Windows 10: "Win10-Radeon-Pro-Software-Enterprise-20.Q4-Nov10"

Install manually and use any compatible driver from the list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.