0

Good morning,

I am having problems gaining access to my D drive on my Windows 10 machine. I just get an Access is Denied Error. It was working fine on Friday. The drive does still show up in explorer. My login is part of the Administrators group on my pc.

Here is what I have tried so far:

  1. Checked my group policies to see if anything has changed.

  2. Tried the Error checking, by right clicking on the drive, clicking tools -> Check. This gives me the following error : "The disk check could not be performed because Windows can't access the disk"

  3. Checked the security to see if I have access to it.
    This tells me "You must have read permissions to view the properties of this object" Click Advanced to continue.
    Clicking advanced won't show me the owner of the drive.
    I have tried changing the owner to SYSTEM, my login for the domain, my local login.
    In the permission tab it says "You do not have permission to view the objects security properties, even as an administrative user. Try taking ownership." I click change, and set it to one of the users mentioned above, then check the Replace owner on subcontainers and objects.
    Clicking apply gives me: "You do not have permiossion to read the contents of directory D:. Do you want to replace the directory permissions with permissions granting you full control. All permissions will be replaced if you press Yes." I press yes.
    I get "An error occured while applying security information to: D:\ Failed to enumerate objects in the containter. Access is denied."
    I click continue.
    The Windows security message "Unable to set owner on local disk (D:) Access is denied."

  4. Tried running chkdsk on the D drive in both standard and admin command prompt. Get the error: "Access Denied as you don't have sufficient priveleges. You have to invoke this utility running in elevated mode."
    I get that in the Admin Command Prompt

  5. Tried the above running explorer as admin

  6. Tried disconnecting and reconnecting the drive from the mother board just to check the connections.

  7. Tried takeown in standard and admin console. Access Denied error

  8. Tried AccessChk from sysinternals

I have checked the following pages:

Permission error - Failed to enumerate objects in the container. Access is denied.

Failed To Enumerate Objects In The Container, Access Is Denied

Access Denied even though I am an Administrator

Can't take ownership of external hard disk

Access Denied on Local Disk D

Windows 7: Error assigning ownership "Unable to set new owner on.. Access denied"

Can't change permissions or take ownership of Local Disk D:

How to fix ‘Location is Not Available’ Error in Windows 7 & 10

Location is not available

Error: "The disk check could not be performed because windows cannot access the disk."

How to fix – Windows cannot access the disk

I can't access my own files under windows 10

Windows 10: You don’t currently have permission to access folder

How do I regain access to a directory under windows 10

After updating to Windows 10 not able to access E Drive

There are others but I think you get the idea.

The windows specs: Edition: Windows 10 Pro Version 170-9 OS Build: 16299.334

C Drive: SSD D Drive: SSD

The only things that have changed that I can bring to mind recently is, I have installed the latest updates, and removed the hibernate file from my c drive. I have tried removing the updates and setting the hibernate file back, but this hasn't changed anything. If it helps I can add the contents of my Event Viewer.

Any help would be appreciated as I am out of ideas.

Thankyou for your help.

1

I think I have found the solution to the issue. I removed myself from the domain. Logged in as the local Administrator. This allowed me to get access to drive properites. I changed the owner to Everyone and applied the changes. I needed to reboot a couple of times to get access to the directories. Added everyone into the permissions with full control. After that I added myself back into the domain and all seems good. I'm not sure if it was the drive or my domain rights that had gone wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.