Normally, after a domain name is registered, it has some DNS records. But recently, I found some registered domain names that have no DNS records.

For example, I ran dig 00000onlinecasino.com any but it did not return any DNS records, not even the NS record, despite the fact this is a registered domain.

Is it possible to have no DNS records, or is there some error in the DNS system?

  • 4
    How did you find these domains? Mar 27, 2018 at 12:03
  • For example, "dig 00000onlinecasino.com any" can not return any DNS record, even the NS record, although it is a registered domain. In theory, are the domain registration and the DNS two separated systems(although usually they are connected together)?
    – peter
    Mar 27, 2018 at 14:26
  • To see the NS records (which indeed exist for that domain) I think you need to use dig +short NS 00000onlinecasino.com Mar 27, 2018 at 14:31
  • Maybe I'm in bad luck, but that command does not output anything on my machine:-)
    – peter
    Mar 27, 2018 at 14:38
  • 3
    "any" might not be as reliable for that purpose as you think - it certainly is not meant to give you a complete copy of a zone. That's what "axfr" is for, and most DNS servers will reject that query for good reasons. Mar 27, 2018 at 19:37

6 Answers 6


TL;DR It's extremely unlikely (though not technically impossible) that a properly registered domain would have zero* DNS records. The existence of the domain must be announced to the global DNS system by an update provided by the domain registrar. Failure by the Registrar to provide this update would constitute failure to perform the duty delegated to them by the IANA.

At minimum, every domain has one or more DNS glue records

When a domain is registered, the Domain Registrar sends an update to the generic Top-Level Domain (gTLD) servers responsible for the TLD in question. For example, registering the domain example.com triggers an update to the .com gTLD servers, which are operated by VeriSign.

This update includes the authoritative name server (NS) records from the domain's WHOIS data. The gTLD server then creates a DNS glue record for the domain pointing to the authoritative name servers. These glue records are what enable the gTLD servers to refer incoming queries to the authoritative name servers for the domain.

Therefore, unless the domain registrar fails to perform the duty delegated to them by IANA, a lookup against any registered domain will return the authoritative name server records for that domain.

Then why aren't lookups for 00000onlinecasino.com returning any records?

It appears that everything has taken place as described above; in other words, this domain's registrar (NameBright.com) has created the required WHOIS entry and submitted the NS records to the .COM gTLD servers. I confirmed this as follows by running nslookup set to query for NS records:

C:\> nslookup -q=ns 00000onlinecasino.com
Server:  my-dns-server.internal.local

Non-authoritative answer:
00000onlinecasino.com   nameserver = n2.juming.com
00000onlinecasino.com   nameserver = n1.juming.com

n2.juming.com   internet address =
n2.juming.com   internet address =
n1.juming.com   internet address =
n1.juming.com   internet address =

I also used this handy Glue Record checker from MeBSD.com which confirmed the results:

enter image description here

However, the same query when performed against any of these name servers is returning an error:

C:\> nslookup -q=ns 00000onlinecasino.com n1.juming.com
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to UnKnown timed-out

Since these servers are authoritative for this domain, they should at least know about it and identify themselves as the NS records for the domain! Given this, it's clear that these NS servers have been mis-configured.

*I must allow that the definition of "zero DNS records" is open to interpretation. As demonstrated by this question's test case, the authoritative name servers aren't responding, giving cause to the argument that the domain has no records. However, I prefer the view that a domain's glue records are essentially the "other half" of a domain's NS records. After all without the glue records, any attempts to look up the authoritative name servers for a domain would result in the circular instruction to, "go ask [insert name server here]."

More Information

  • Not necessarily consistent with my experience lo these many years ago when I first registered my domain - will a registrar assign a 'dummy' NS address to a brand new domain that doesn't have a host ready yet? Mar 27, 2018 at 12:13
  • I'm unsure what you mean by "dummy NS address", though it feels like you may be unclear on what NS records do. In short, they tell the Internet which DNS server is authoritative for DNS lookup requests for said domain. The concept of a dummy record doesn't make sense here. Mar 27, 2018 at 12:23
  • Example: My hosting company is not my registrar, and my hosting company's name servers provide the authoritative answers for the addresses of my domain's web and mail server. Before I activated my hosting, but after I'd paid my money to my registrar for the domain name, what would the NS records have pointed to? Mar 27, 2018 at 12:27
  • 3
    They would have pointed to the registrar's name servers. That's always where they point unless changed. Mar 27, 2018 at 12:31
  • 2
    You have to supply NS records in your whois registration. Those NS servers are free then to say "as far as we know this domain doesn't exist" but because they are authoritative, this is then the authoritative answer.
    – tripleee
    Mar 27, 2018 at 12:46

Yes. There are multiple ways this can happen.

To start, let's review how DNS lookup works for a record like www.example.com:

  • The DNS resolver contacts a root nameserver, which responds with a delegation to the com TLD nameservers.

  • The resolver contacts a com TLD nameserver, which responds with a delegation to the registered nameservers for example.com.

  • The resolver contacts one of the registered nameservers for example.com, which responds with the records for www.example.com.

First: the nameservers for example.com could have deleted all records for example.com. While domain servers are supposed to always have certain records (including SOA and NS records) available for a domain, there is nothing in practice which forces them to do so. A domain missing these records may not work properly with some resolvers, but if the domain has no DNS records anyways there's no practical difference.

Second: the nameservers for example.com could reject or fail to respond to queries. The DNS records only exist within these nameservers, so if the nameservers aren't responding with the records, the records effectively don't exist.

Third: the com registry could suspend the registration for example.com, e.g. if the domain registration lapsed. This would cause the com nameservers to stop returning a delegation to the example.com nameservers, making any records there unavailable. Just as before, if the records aren't accessible, they might as well not exist.


There are 2 parts to registering the domain - getting it allocated by the registry and setting up a DNS.

For most (all?) domains, DNS name server entries need to be provided for the domain to be registered (different tlds have different requirements but most require a minimum of 2 servers be specified). Often, however, there is no requirement that these nameservers are valid, so you can get away with putting anything in these fields.

The second part is setting up the zone on the nameservers. Generally it's possible to leave this step out when registering a domain name, but a lot of registrars will setup default entries as part of your registration.

So, no, it's not possible to not specify any nameservers in most cases, but the specified nameservers don't need to work. In this case, whois (which queries the registrar database) will generally show the nameservers, but dig/nslookup (which relies on DNS working) won't, although I have seen domains with no nameservers specified.

  • 1
    Yes, just now, I tried to change the name servers of one of my domains from the default ones to empty but failed. That means providing name servers to registry is a mandatory step in registering domains. Thank you for your answer,@davidgo!
    – peter
    Mar 28, 2018 at 17:06
  • "whois (which queries the registrar database)" this is false. Each registry has a whois server and any whois client first query the registry whois server and in some cases, specifically .COM/.NET as they are thin (still), there is a need to contact the registrar whois server to get all the missing data, mostly the contact details. Apr 6, 2018 at 5:28
  • @peter "That means providing name servers to registry is a mandatory step in registering domains." This is completely false. No technical standard nor policy enforce this. You are completely free to register domain names without nameservers. Apr 6, 2018 at 5:29
  • @PatrickMevzek Which registrar will allow you to register a domain name with entries for DNS, and for what TLDs?
    – davidgo
    Apr 6, 2018 at 5:39
  • @davidgo Sorry I do not parse your question. Any competent registrar will let you register a domain name in any TLD it manages without putting nameservers. This is a basic feature. Apr 6, 2018 at 5:41

It would help if you could join some screenshots of what you are getting.

But without this information, I theorize that you are looking in the wrong place.

When a specific name server is not specified in the command invocation, dig will look in your /etc/resolv.conf file and will query the DNS servers that are listed in there.

If the domain you are searching for is not listed with the DNS servers in your copy of resolv.conf, then it will not be found.

You should add to the file a DNS server for that domain, or specify it on the dig command, by preference one that can give an authoritative answer.

  • It used as the name server. dig command does not return any DNS record. I even used the authority name server as seen in the sceenshot provided by @Twisty Impersonator, but that server seems dead("connection timed out; no servers could be reached"). That might explain why could not return DNS records as well.
    – peter
    Mar 27, 2018 at 16:02
  • 1
    Yes, that's the likeliest supposition : The records were not available on any reachable DNS server.
    – harrymc
    Mar 27, 2018 at 16:56

It's entirely possible for a domain to be registered, but not have a DNS entry - if I've registered a domain, but haven't actually purchased hosting and activated the site that will be associated with the domain, there's nothing for it to resolve to.

  • 5
    -1 because its not entirely true.
    – LPChip
    Mar 27, 2018 at 11:53
  • 1
    @LPChip - Would you care to elaborate on that? It certainly matches my experience when I first got my hobby domain... Mar 27, 2018 at 11:54
  • See my answer. :)
    – LPChip
    Mar 27, 2018 at 11:55
  • @LPChip - Now please explain how a SRV record can exist if I don't have a place to host yet. Mar 27, 2018 at 11:56
  • 1
    @JeffZeitlin: 1) Not all domain registrar sell domains + web hosting in a semi-package. DNS hosting is a completely independent service from web hosting (or mail hosting or other hosting). 2) DNS records of your domain are not required to point to your web server. They can point to a server which doesn't host websites; or to someone else's; or to a nonexistent server. 3) DNS does more than just "pointing to a server": there are plenty of DNS record types with different purposes than that. For example all correctly configured domains have SOA and NS records linking the domain with its parent.
    – user1686
    Mar 28, 2018 at 4:49

If the registrar is doing their job there should at least be some NS records. Sometimes you will get null result if your dns requests more than just NS records. I still come across domains that dont have NS records however, for example: buyhouse.com.au

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.