1

My problem

Whenever I download a large amount of data (ex: downloading a game from Steam), my entire PC comes to a crippling low <1 frame per second, despite having relatively decent hardware. This only seems to happen with large downloads as I can download single images and webpages without issue. To make matters more confusing, this issue used to not be present on this machine prior to being upgraded to Windows 10 (from Windows 7 Home) as well as potentially for a short period afterwards that I don't recall the issue occurring. Another thing to note is that I do not have WiFi in this computer, only Ethernet.

My question

What is the cause of this poor performance I am experiencing and how do I fix this?

My theory

It would seem that Windows insists on downloading large downloads on the first core listed in task manager every time. This is supported by this screenshot of Task Manager that I took while downloading a game:

Task manager showing high single core usage

Processes running while downloading a game:

Task manager showing running processes

I do not know if this is the intended behavior or if it is actually the root of the problem. But so far I don't have any evidence that disqualifies it.

Things I have tried

  • Updating my Ethernet driver (Realtek PCIe GBE Family Controller) multiple times
  • Adjusting my power plan
  • Making sure Windows is up to date.
  • Using latencymon to investigate driver latency. It frequently shows massive latency with ndis.sys (when downloading files) that I have been unable to resolve. I assume this is related in some way.

My relevant system specs

  • Windows 10
  • AMD FX-8150 CPU
  • GTX 1060 6GB GPU
  • 16 GB 1600Mhz DDR3 RAM
  • Multiple drives (boots from a 256GB Corsair SSD)
14
  • does this only happen in steam, or also in browsers and other downloaders? Mar 28, 2018 at 2:53
  • @Richie It happens outside of steam too. Most recently I tried downloading Fortnight using the Epic Games Launcher and it suffered from the same problem.
    – That Guy
    Mar 28, 2018 at 3:03
  • Can you tell what process uses the CPU the most? How about antivirus and its settings regarding network connection and data being downloaded? Mar 28, 2018 at 5:31
  • What antivirus do you have?
    – Mokubai
    Mar 28, 2018 at 6:32
  • 1
    btw, the statement that "It would seem that Windows insists on downloading large downloads on the main thread and nothing but the main thread" is... odd. I have no idea what you mean by "the main thread". Threads are parts of processes and as far as Windows at large is concerned there is no "main thread". Most programs do have a thread that could be considered the "main thread" but it is up to each process's developer to decide which one or several of a process' threads performs any download. All that said, downloading should be an I/O bound job; it should not take appreciable CPU time. Mar 29, 2018 at 5:27

1 Answer 1

2

Analyzing the ETL shows that Interrupt/DPC are caused by the driver vsdatant.sys which seams to be part of ZoneAlarm firewall.

enter image description here

enter image description here

So remove ZoneAlarm, reboot and look if downloading is faster and using less CPU.

11
  • Wow, that did it! In hindsight, I can't believe I overlooked something so obvious. Thanks for the investigation. Hopefully this will be helpful for some other ZoneAlarm user who's as confused as I was.
    – That Guy
    Mar 30, 2018 at 23:56
  • Ah, scratch that. It appears my celebration was premature. After using my computer for a short while (after uninstalling ZoneAlarm and restarting) it appears the issue is back once again. Here's a new ETL zip: link
    – That Guy
    Mar 31, 2018 at 0:05
  • still the same issue. vsdatant.sys is causing the DPC usage. Use ProcessHacker to stop the driver under the services tab. here you can also delete the driver entries. also remove the driver from system32/drivers folder. Mar 31, 2018 at 14:05
  • Well now I am thoroughly confused as ProcessHacker doesn't display that driver under services and it would seem that the issue is now gone (again)? I have no clue what's going on, but I'm not complaining if it's actually resolved for good this time. Is it possible that I would have had to restart my system multiple times to fully remove it?
    – That Guy
    Mar 31, 2018 at 19:33
  • If the problem doesn't reoccur in the next couple days, I'll accept this as the answer.
    – That Guy
    Mar 31, 2018 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.