0

Note: I'm offering this self-answered question hoping it will spare others similar troubles. I don't know what other Netgear router models are affected.

Prerequisites:

  • The Comcast/Xfinity cable modem itself has Internet connectivity (verifiable via a direct-to-a-computer Ethernet connection) and - if the modem isn't just a modem but also has a Wifi router built in (residential gateway) - it must be in bridge mode.

  • The cable modem has been power-cycled and given enough time to come online before you've connected the router to it by Ethernet cable. When in doubt, power-cycle both devices and do not reconnect the router until the cable modem is back online.

Symptoms:

  • The router never manages to connect to the Internet via the cable modem - the Internet-connectivity LED on the device remains orange (white is what indicates an established connection)

  • The router's web-based administration application at http://192.168.1.1 tries to connect, fails, offers to try again, and keeps failing.

0

Presumably, the automated setup fails, because the router unexpectedly submits an account-name field containing the router's model number when trying to register with Comcast's WAN.

The workaround is to configure the connection manually:

  • Connect to the router's web-based administration application at http://192.168.1.1

    • If the page was previously open, refresh it.
  • This will trigger an automatic setup attempt - wait for it it to fail.

  • On failure, choose the option "I want to set it up myself" (or similar wording).

  • On the manual configuration page:

    • Clear the "Account Name (If Required)" field (the password field should be empty anyway).
    • Set all other options to either "Dynamic" (IP address) or "Automatic" (DNS server addresses, MAC address)
    • Click "Apply", at which point, after a minute or so, the connection should succeed: a new page should tell you so, and the router's LED should have turned white.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.