0

On macOS High Sierra 10.13.3 - I switched from using built in apachectl/httpd, to using Homebrew installed version.

For some reason, 127.0.0.1 and localhost both redirect to a local.dev hostname, which loads a site in a sub-directory of my web root.

I have tried:

  1. Clearing out /etc/hosts
  2. Disabling all htaccess files in directories that I use
  3. Clearing and restarting local DNS cache
  4. Different browsers (all behave the same)
  5. Removing all default apache startup/launch processes/daemons
  6. Removing homebrew's httpd launch item so I can enable it manually

For the life of me I cannot access the directory that I point to in httpd.conf as my web root. Typing in 127.0.0.1 and/or localhost always redirects me to local.dev

I'm at a loss.

  • can you open a shell and type in "cat /etc/hosts" once more? It should not be empty, rather it should contain "127.0.0.1 localhost 255.255.255.255 broadcasthost ::1 localhost" – MikeP Mar 29 '18 at 20:38
  • Also "cat /private/etc/hosts". – MikeP Mar 29 '18 at 20:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.